Hi there,

I need some solutions or hints to my problem.
Currently, I am taking over an application that was developed by previous programmer.
The application is a desktop based and installed in a network drive.

On my pc, which is in domain A, I could run the application flawlessly.
But, I couldn't do the same from another pc, which is in domain B.

I have tried many suggestions from people on internet, such as .Net framework permission, re-register assembly, and other setups, but nothing helps.

When I run the application from a pc in domain B, it keeps giving me an error
XXXXX.exe - Common Language Runtime Debugging Services
Application has generated an exception that could not be handled
Process id=0x654(1620), Thread id = 0x5b0 (1456)
Click OK to terminate the application
Click CANCEL to debug the application

Then I click on cancel button to see what happens and it gives me System.IO.FileNotFoundException.

I even copied the files to the local hard drive pc in domain A and still runs fine, but not the pc in domain B.

Any suggestions and advices would be really appreciate.

Welcome ericware.

You need to ensure that both development and deploying machine must have same framework version.
Have a look at a thread at social msdn.


Thanks for the reply.
I had checked the framework version already.
PC in domain A and B have exactly the same framework version.
I tried to uninstall and reinstall all the framework version installed but still no luck.

Any suggestions and advices would be really appreciated.

This article has been dead for over six months. Start a new discussion instead.