Hello,

I have installed the latest versions of OpenCV and Eclipse CDT, but not able to make OpenCV to be used within Eclipse CDT.

Any ideas on how can I do that?

Thanks a lot.

Edited 5 Years Ago by SWEngineer: n/a

If you just Googled "OpenCV and Eclipse CDT", you would have found this, and a lot of other helpful links, and saved the time taken to type and post in multiple forums.

I actually found this post but didn't work with me. And, that is why I wrote latest in italics in my question.

Did you manage getting OpenCV to work with Eclipse for their latest versions?

Edited 5 Years Ago by SWEngineer: n/a

No. I use visual studio. What problems are you facing when you follow the given link? Please be as descriptive as possible.

No. I use visual studio. What problems are you facing when you follow the given link? Please be as descriptive as possible.

The case is that since this is the first time doing this, I wanted a tutorial to follow.

The link provided for example has a step where selected is

Manage Make C++ Project

, which I don't have, and from here the issue started.

Also, there is a step where Directories are selected under GCC C++ Complier, and the case is that I don't have directories, and the compiler is Cygwin C++ Compiler.

And, this is what I'm trying to configure:

http://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/heliossr2

http://sourceforge.net/projects/opencvlibrary/files/opencv-win/2.2/

Any ideas?

Thanks.

Okay. So from what I understand, before setting up OpenCV, you have to setup Eclipse so that you can compile and link a basic C/C++ program, right?
Follow this link, and see if you can get to compile, link and run a basic Hello World program.
If you can't, post the problems you are having.
If you can, continue with the OpenCV setup for Eclipse.

Okay. So from what I understand, before setting up OpenCV, you have to setup Eclipse so that you can compile and link a basic C/C++ program, right?
Follow this link, and see if you can get to compile, link and run a basic Hello World program.
If you can't, post the problems you are having.
If you can, continue with the OpenCV setup for Eclipse.

Thanks for your reply.

Regarding the link you provided, did you use it to get OpenCV to work with Eclipse at all?

Edited 5 Years Ago by SWEngineer: n/a

This article has been dead for over six months. Start a new discussion instead.