Hello,

I've finally come to a point when I want to send my program over to some people to test, however, I've run into problems on that.

This is my first time writing a program in managed code(C++\CLR), and so far, all I had to do was pack the redistributional package along with my files, however, it seems to be more difficult for managed code, as opening the program on a different computer brings up the "This application has failed to start because the application configuration is incorrect" error.

Browsing online told me that to solve this I need to statically link the project with the /MT compiler switch, however, the program being managed, I need the /clr command line option for it to compile at all, and that allows only the use of /MD.

So... How do I get around this? Any ideas?

Any help would be appreciated,
Thanks.

TBH, I dont know what "This application has failed to start because the application configuration is incorrect" has to do with statically linking the project.. I can tell you that this happens to me a shitload of times.. especially when using VS2010 x64 omg.. must be the worst compiler. Usually when I get that error, I get an option to press details and stuff and when pressed it shows kernel32.dll and some weird AMDx64 crap... Just compile it as x86 or x32.. sometimes in the VS2010 x64 compiler, even when you choose x32, it still doesnt work.

Solution:
Compile it with VS2008 and choose x32 next to the debug/release option.. It will work for sure. Well at least that worked for me.

Well, I already was compiling on VS2008 with x32, so I guess that is not it =\

Maybe your vs2008 x32 is messed up like my vs2010 x32 option.. even though it says x32 it keeps compiling in x64 for some stupid reason.. and reinstalling didnt help me.. If you want I can compile it and see.

Try compiling a "Release" version instead of a "Debug" version. Then make sure you send the files from the "Release" folder instead of the "Debug" folder. They link to different libraries.

Because of the library differences, a "Debug" version will only run on a system that has VS installed on it. If you try to run it on an incompatible system, you'll get an application configuration error because it's looking for the wrong libraries.

Edited 5 Years Ago by Fbody: n/a

Should've tried that earlier ._.

That worked, fixed the problem, thanks alot =)

This question has already been answered. Start a new discussion instead.