when I try to run a java program on my mac or linux box with the
<code>
java -version:1.6+ -jar jdesigner.jar
</code>
it tells me there is no jre found meeting the requirements even though when I type

<code>
java -version
</code>

it tells me the version is 1.6.0_20 or some such. I have tried the exact string as well, no luck.

--douglas

Recommended Answers

What OS are you running on the Mac? 10.5 has real problems with Java 6. If you're running under 10.6, I'll be able to tell you more about that in a few days - I just upgraded yesterday. :)

Shouldn't be a problem under Linux, though. Which distro?

Jump to Post

All 2 Replies

What OS are you running on the Mac? 10.5 has real problems with Java 6. If you're running under 10.6, I'll be able to tell you more about that in a few days - I just upgraded yesterday. :)

Shouldn't be a problem under Linux, though. Which distro?

ubuntu 10.10

I am running OSX 10.5. I don't have a problem with the 1.6 installation (though I do recall it being a pain to get it installed) but I want to be able to require something. I figured out how to do it on the mac with the jar bundler at least so that part is taken care of.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.21 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.