Hi,
I made setup file, i install it on windows 7, it install successfully , when i execute using shortcut key or .exe file it gives a message "application has stop working" and not open any form and close automatically.

Edited 5 Years Ago by bhagvad301: n/a

Did you forget to include any reference or application files to the installer?

Go to your project, into Solution explorer, right mouse click on the Project name, and select Properties. Go to Publish tab, and click on Application Files and Prerequisites.
Check in both if there is anything missed out not be included in the installer version.

Hi,
I made setup file, i install it on windows 7, it install successfully , when i execute using shortcut key or .exe file it gives a message "application has stop working" and not open any form and close automatically.

i think you missing some component while making DLL setup. make new setup and try with other OS

i think you missing some component while making DLL setup. make new setup and try with other OS

??
1st of all, that`s a part what I explained, and your 2nd statement has no point.
Or you do a complete explanation, or you better do nothing. Iam sure he has no clue what were you talking about (even I am hardly awaring of what you were saying).

Please, next time do better work... ok?

hi Mitja,

I check in both prerequisites both are using same component. if there is another way please tell me.

Edited 5 Years Ago by bhagvad301: n/a

If you included all what you use in the project, it shoud work after publishing and installing the project.

And if you run the project from VS there is no problem at all? Go thorugh all the code from the beginning with putting a break point. Check what might be wrong, if there is any special code included (thaqt code which might use some prerequisites).

Hi Mitja,
its working fine in VS, setup is install successfully. after installing when i click in icon then it give error message.

Edited 5 Years Ago by bhagvad301: n/a

Maybe you didn`t set the shortcut of the project correctly.
Then I dont know what could be else. As a matter of fact, nothing can be wrong.
Or some missing prerequisites, or there is something wrong with starting your application - so the shortcut to run the exe file.

I think may be it is virus problem.

another,any missing files.

Edited 5 Years Ago by Narue: Snipped fake signature.

This article has been dead for over six months. Start a new discussion instead.