code removed for privacy reasons.
if(isPalindrome = false)
Change it to
if(isPalindrome == false)
because "=" means you assign the value to the variable while "==" means comparing the value with the variable. However You could do
because it is a boolean and you could use it right away as "true" or "false" (or !false is true and vice versa)...
PS: You may have argument mismatch exception in your retrieveInput() method if a user enter something which is not all digit number...