I am making a voice recognizer for my media player so as to stop and play the song through my voice .I tried to run a demo program given in the sphinx src through command prompt .I have also used apache ant to build sphinx pgm .when irun the demo pgm through ANT COMMAND it gives the following error


Buildfile:Built.xml doesnot exist.
can any one tell how to remove the error.

Thanks in Advance.

You have to execute ant call from inside Sphinx directory on the same level as is build.xml. Checking their SVN it is clearly there on top level in the directory as expected

Hi, I tried to run a demo example of HelloWorld.jar given in sphinx's bin and it runs b'coz it was a jar file but when i make a java file and tried to run it through command prompt it won't work .

I am getting an error of Buildfile:build.xml does'nt exist.
so tell me the steps of packing my java pgm into a jar file so that i can run it with
the following command java -Xmx256m -jar bin/HelloWorld.jar.
Also i am using apache ant to build my sphinx and my pgm.but i am still getting the same error .
I have set three Environment variables.
ANT_HOME:D:\project\ant
JAVA_HOME:C:\Program Files\Java\jdk1.6.0
PATH:%PATH%;%ANT_HOME%\bin

I run the ANT command by first going to the sphinx directory -> cd /D:\project\Sphinix-4
Now irun the ANT command which gives following error.

Buildfile:build.xml does'nt exist.
Build failed.

please help me to overcome this error .please reply fast it's very very urgent as i have to submit my project on voice recognition media player within a week .
bythe way i have made the madia palyer in java but only i needed is the help on sphinx so that i can stop and play the madia through my voice.
Thanks in Advance.

1. I do not see for you to create multiple threads while all of them are asking same thing just with extra info difference, therefore threads merged. Make sure you do not do this again
2. Proper English is expected of any member so stuff like "b'coz" or "pgm"
3. What do you get when you execute ant -diagnostics ?

PS: It is recommended to have development tools easy accessible like for Windows C:\ant not inside project directories etc.

Edited 5 Years Ago by peter_budo: n/a

thanks for the reply peter .
with ANT command i am getting the following error
Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre1.6.
0\lib\tools.jar
Buildfile: build.xml does not exist!
Build failed

and with the ant -diagnostics i am getting the following output
D:\Sphinix-4\sphinx4-1.0beta6-src\sphinx4-1.0beta6\src\apps\edu\cmu\sphinx\demo\
helloworld>ANT -diagnostics
Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre1.6.
0\lib\tools.jar
------- Ant diagnostics report -------
Apache Ant(TM) version 1.8.2 compiled on December 20 2010

-------------------------------------------
Implementation Version
-------------------------------------------
core tasks : 1.8.2 in file:/D:/ant/lib/ant.jar

-------------------------------------------
ANT PROPERTIES
-------------------------------------------
ant.version: Apache Ant(TM) version 1.8.2 compiled on December 20 2010
ant.java.version: 1.6
Is this the Apache Harmony VM? no
Is this the Kaffe VM? no
Is this gij/gcj? no
ant.core.lib: D:\ant\lib\ant.jar
ant.home: D:\ant

-------------------------------------------
ANT_HOME/lib jar listing
-------------------------------------------
ant.home: D:\ant
ant-antlr.jar (5748 bytes)
ant-apache-bcel.jar (8746 bytes)
ant-apache-bsf.jar (3931 bytes)
ant-apache-log4j.jar (3059 bytes)
ant-apache-oro.jar (39638 bytes)
ant-apache-regexp.jar (3761 bytes)
ant-apache-resolver.jar (4084 bytes)
ant-apache-xalan2.jar (2295 bytes)
ant-commons-logging.jar (3913 bytes)
ant-commons-net.jar (85511 bytes)
ant-jai.jar (22265 bytes)
ant-javamail.jar (7960 bytes)
ant-jdepend.jar (8222 bytes)
ant-jmf.jar (6739 bytes)
ant-jsch.jar (40175 bytes)
ant-junit.jar (102220 bytes)
ant-junit4.jar (7120 bytes)
ant-launcher.jar (12322 bytes)
ant-netrexx.jar (10392 bytes)
ant-swing.jar (7555 bytes)
ant-testutil.jar (15201 bytes)
ant.jar (1933743 bytes)

-------------------------------------------
USER_HOME/.ant/lib jar listing
-------------------------------------------
user.home: C:\Documents and Settings\Administrator
No such directory.

-------------------------------------------
Tasks availability
-------------------------------------------
image : Missing dependency javax.media.jai.PlanarImage
sshexec : Missing dependency com.jcraft.jsch.Logger
wlrun : Not Available (the implementation class is not present)
scp : Missing dependency com.jcraft.jsch.Logger
stlist : Not Available (the implementation class is not present)
sshsession : Missing dependency com.jcraft.jsch.Logger
starteam : Not Available (the implementation class is not present)
stlabel : Not Available (the implementation class is not present)
jdepend : Missing dependency jdepend.xmlui.JDepend
stcheckin : Not Available (the implementation class is not present)
stcheckout : Not Available (the implementation class is not present)
ejbc : Not Available (the implementation class is not present)
wlstop : Not Available (the implementation class is not present)
ddcreator : Not Available (the implementation class is not present)
A task being missing/unavailable should only matter if you are trying to use it

-------------------------------------------
org.apache.env.Which diagnostics
-------------------------------------------
Not available.
Download it at http://xml.apache.org/commons/

-------------------------------------------
XML Parser information
-------------------------------------------
XML Parser : com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl
XML Parser Location: unknown
Namespace-aware parser : com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$J
AXPSAXParser
Namespace-aware parser Location: unknown

-------------------------------------------
XSLT Processor information
-------------------------------------------
XSLT Processor : com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl
XSLT Processor Location: unknown

-------------------------------------------
System properties
-------------------------------------------
java.runtime.name : Java(TM) SE Runtime Environment
sun.boot.library.path : C:\Program Files\Java\jre1.6.0\bin
java.vm.version : 1.6.0-b105
ant.library.dir : D:\ant\lib
java.vm.vendor : Sun Microsystems Inc.
java.vendor.url : http://java.sun.com/
path.separator : ;
java.vm.name : Java HotSpot(TM) Client VM
file.encoding.pkg : sun.io
user.country : US
sun.java.launcher : SUN_STANDARD
sun.os.patch.level : Service Pack 2
java.vm.specification.name : Java Virtual Machine Specification
user.dir : D:\Sphinix-4\sphinx4-1.0beta6-src\sphinx4-1.0beta6\src\apps\edu\cmu\s
phinx\demo\helloworld
java.runtime.version : 1.6.0-b105
java.awt.graphicsenv : sun.awt.Win32GraphicsEnvironment
java.endorsed.dirs : C:\Program Files\Java\jre1.6.0\lib\endorsed
os.arch : x86
java.io.tmpdir : C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\
line.separator :

java.vm.specification.vendor : Sun Microsystems Inc.
user.variant :
os.name : Windows XP
ant.home : D:\ant
sun.jnu.encoding : Cp1252
java.library.path : C:\WINDOWS\system32;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\sys
tem32;C:\WINDOWS;C:\Program Files\PC Connectivity Solution\;C:\WINDOWS\system32;
C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Common Files\Autodesk Share
d\;C:\Program Files\PC Connectivity Solution\;C:\WINDOWS\system32;C:\WINDOWS;C:\
WINDOWS\System32\Wbem;C:\Program Files\Common Files\Autodesk Shared\;D:\ant\bin
java.specification.name : Java Platform API Specification
java.class.version : 50.0
sun.management.compiler : HotSpot Client Compiler
os.version : 5.1
user.home : C:\Documents and Settings\Administrator
user.timezone : America/Los_Angeles
java.awt.printerjob : sun.awt.windows.WPrinterJob
file.encoding : Cp1252
java.specification.version : 1.6
user.name : Administrator
java.class.path : D:\ant\lib\ant-launcher.jar;D:\ant\lib\ant-antlr.jar;D:\ant\li
b\ant-apache-bcel.jar;D:\ant\lib\ant-apache-bsf.jar;D:\ant\lib\ant-apache-log4j.
jar;D:\ant\lib\ant-apache-oro.jar;D:\ant\lib\ant-apache-regexp.jar;D:\ant\lib\an
t-apache-resolver.jar;D:\ant\lib\ant-apache-xalan2.jar;D:\ant\lib\ant-commons-lo
gging.jar;D:\ant\lib\ant-commons-net.jar;D:\ant\lib\ant-jai.jar;D:\ant\lib\ant-j
avamail.jar;D:\ant\lib\ant-jdepend.jar;D:\ant\lib\ant-jmf.jar;D:\ant\lib\ant-jsc
h.jar;D:\ant\lib\ant-junit.jar;D:\ant\lib\ant-junit4.jar;D:\ant\lib\ant-launcher
.jar;D:\ant\lib\ant-netrexx.jar;D:\ant\lib\ant-swing.jar;D:\ant\lib\ant-testutil
.jar;D:\ant\lib\ant.jar
java.vm.specification.version : 1.0
sun.arch.data.model : 32
java.home : C:\Program Files\Java\jre1.6.0
java.specification.vendor : Sun Microsystems Inc.
user.language : en
awt.toolkit : sun.awt.windows.WToolkit
java.vm.info : mixed mode
java.version : 1.6.0
java.ext.dirs : C:\Program Files\Java\jre1.6.0\lib\ext;C:\WINDOWS\Sun\Java\lib\e
xt
sun.boot.class.path : C:\Program Files\Java\jre1.6.0\lib\resources.jar;C:\Progra
m Files\Java\jre1.6.0\lib\rt.jar;C:\Program Files\Java\jre1.6.0\lib\sunrsasign.j
ar;C:\Program Files\Java\jre1.6.0\lib\jsse.jar;C:\Program Files\Java\jre1.6.0\li
b\jce.jar;C:\Program Files\Java\jre1.6.0\lib\charsets.jar;C:\Program Files\Java\
jre1.6.0\classes
java.vendor : Sun Microsystems Inc.
file.separator : \
java.vendor.url.bug : http://java.sun.com/cgi-bin/bugreport.cgi
sun.cpu.endian : little
sun.io.unicode.encoding : UnicodeLittle
sun.desktop : windows
sun.cpu.isalist :

-------------------------------------------
Temp dir
-------------------------------------------
Temp dir is C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\
Temp dir is writeable
Temp dir alignment with system clock is 16 ms

-------------------------------------------
Locale information
-------------------------------------------
Timezone Pacific Standard Time offset=-28800000

-------------------------------------------
Proxy information
-------------------------------------------
Java1.5+ proxy settings:
Direct connection.

Actually i have run the demo helloworld.jar which is in
D:\Sphinix-4\sphinx4-1.0beta6-bin\sphinx4-1.0beta6\bin

but how to run the demo example given in
D:\Sphinix-4\sphinx4-1.0beta6-src\sphinx4-1.0beta6\src\apps\edu\cmu\sphinx\demo\helloworld

in sphinx4-1.0beta6-src ,it is a java file .I am not able to run this program.

i get the following error while running "build.xml" file when connecting sphinx 4 with eclipse
BUILD FAILED
F:\project\sample\src\build.xml:228: The following error occurred while executing this line:
F:\project\sample\src\build.xml:397: The following error occurred while executing this line:
F:\project\sample\src\build.xml:445: Warning: Could not find file F:\project\sample\src\src\sphinx4\edu\cmu\sphinx\linguist\acoustic\tiedstate\PropertiesDumper.java to copy.


plz help

thanx in advance

This article has been dead for over six months. Start a new discussion instead.