I'm building pdf software with multiple dependencies (podofo) and when compiling I'm getting the errors.

error: conflicting declaration 'typdef short int unit 8'
error: conflicting declaration 'typdef short int unit 16'

Would anyone know if there a CXX Define command I can use to bypass these errors? My CXX flags module is below. I've already added -DHAVE_BOOLEAN to get rid of a boolean error (as you can see). This has worked.

# Generated by "MinGW Makefiles" Generator, CMake Version 2.8

# compile CXX with C:/CodeBlocks/MinGW/bin/g++.exe
# compile RC with C:/CodeBlocks/MinGW/bin/windres.exe
CXX_FLAGS = @CMakeFiles/podofo_static.dir/includes_CXX.rsp   -Wall -Woverloaded-virtual -Wswitch-enum -Wcast-qual -Wwrite-strings -Wredundant-decls -Wreorder -Wold-style-cast


RC_FLAGS =   -IC:\libjpeg\jpeg-8a -IC:\boost_1_52_0 -IC:\libpng -IC:\zlib -IC:\boost_1_52_0 -IC:\podofo-0.9.1\podofo_debug -IC:\podofo-0.9.1 -IC:\podofo-0.9.1\src -IC:\freetype2-source\freetype-2.4.11\include -IC:\podofo-0.9.1\vcincludes    -Wall -Woverloaded-virtual -Wswitch-enum -Wcast-qual -Wwrite-strings -Wredundant-decls -Wreorder -Wold-style-cast



QuotHow about you show us the relavent code lines and the full compiler output.ed Text Here

I'm building a library not compiling a program.
Thats all the output there is. The inputs are the multiple include and library directories of all the dependencies I have used.

Problem solved now anyway. I simply used an earlier version of cmake to generate a makefile which for some odd reason resolves the problem.

This article has been dead for over six months. Start a new discussion instead.