0

Hi Again,

I have now completed my project and have deployed it successfully, however, i have some ilmerge and obfuscator post build commands that run successfully (I assume, as there are no errors). However, when i deploy the project using an installshield project, and install it on a test computer, it still has all the dll files that i have tried to merge using ilmerge, in the program files folder. I have not tested to see if the obfuscate command worked.

if /I "$(ConfigurationName)" == "Release" copy "$(TargetPath)" "$(TargetDir)$(TargetName)Tmp.exe"

if /I "$(ConfigurationName)" == "Release" "C:\Program Files (x86)\Microsoft\ILMerge\ILMerge.exe" /out:"$(TargetPath)" "$(TargetDir)$(TargetName)Tmp.exe" "$(TargetDir)dllfileshere.Dll" /internalize

if /I "$(ConfigurationName)" == "Release" Eazfuscator.NET.exe "$(TargetPath)" --msbuild-project-path "$(ProjectPath)" --msbuild-project-configuration "$(ConfigurationName)" --msbuild-project-platform "$(PlatformName)" --msbuild-solution-path "$(SolutionPath)" -n --newline-flush -v 3.3

if /I "$(ConfigurationName)" == "Release" del "$(TargetDir)$(TargetName)Tmp.exe"

Wondering if anyone knows whats going wrong?

Thanks, Shaun.

1
Contributor
1
Reply
28
Views
4 Years
Discussion Span
Last Post by shaun.b
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.