0

Dear friends,
I completed my script that makes use of opencv (import cv2) and I am experiencing problems with py2exe and other similar compiler.
I work on a win7 64bit machine but all my packages and python (2.7) are 32bit because I was already planning to distribute my software on 32bit machines too.
When I try to run it on a 32bit winxp sp3 virtual machine, I get the error

  File "zipextimporter.pyo", line 98, in load_module
ImportError: MemoryLoadLibrary failed loading cv2.pyd

I found a number of possible solutions for similar problems on the web but none of them seems to work!
I really need your help and hope you can address me to the right solution.
Thanks a lot,
Gianluca

2
Contributors
3
Replies
16
Views
4 Years
Discussion Span
Last Post by giancan
0

The point is that until now it always worked correctly, exactly because I didn't mix 32 and 64 bit.
The problem appears since I add opencv to the program and it seems to be a py2exe issue.
Any help?

0

I recompiled everything on a winxp 32bit machine but I still get a crash of the app without explaination. May it be a problem with numpy or scipy (used together with opencv)?
is there any compatibility issue within the last version of each of them?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.