**Ok the problem is this. I have the groups I want added to the administrator, and remote desktop users group on the local machine, and all that works fine. If you hit windowsKey+pause , or right click on "My Computer" and go to advanced settings, remote tab. At the top it has a check box "Allow Remote Assistance" I cannot script this box to be auto check marked. We do have UAC turned on, but I can do it manually and I get no prompt from UAC so I doubt that's preventing this ** I simply need to script that "Allow Remote Desktop" to be check marked. Any assistnace would be greatly appreciated. (Maybe Ancient Dragon is still around.. that guy's been helping me for years I wished I could buy him a beer or something).

    MessageBox(0,
                        "STARTING INSTALLATION",
                        "Codys Installer",
                        MB_ICONINFORMATION);
                        //ADD  Domain Support III to proper groups
                        system("net localgroup administrators /add \"Domain Support III\" && exit");
                        system("net localgroup \"Remote Desktop Users\" /add \"Domain Support III\" && exit");
                        system("reg add \"HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Terminal Server\" /v fDenyTSConnections /t REG_DWORD /d 0 /f");
                        system("reg add \"HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Terminal Server\" /v fAllowToGetHelp /t REG_DWORD /d 1 /f");


                        MessageBox(0,
                        "PAUSING FOR DEVELOPMENT TESTING",
                        "Codys Installer",
                        MB_ICONINFORMATION);

I figured it out. Dis-regard, I was missing the value data of 1 , and when I would quickly check the remote assistance checkbox it took a little before the check box miraculously displayed the checkmark. So I just needed a little more patience.

Edited 3 Years Ago by CodyOebel

This question has already been answered. Start a new discussion instead.