intelharsh 0 Newbie Poster

I have installed Ubuntu 12.04 on VMWare 6.0 with Windows 7 as host. I am trying to access my webcam on Ubuntu but I'm successful only once in a while.

The results for lsusb is :

harsh@ubuntu:~$ lsusb
Bus 001 Device 002: ID 046d:082d Logitech, Inc. 
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

But when I run applications like "cheese" or "qv4l2", I get errors like :

(qv4l2)

libv4l2: error turning on stream: Broken pipe
Start Capture: Broken pipe
VIDIOC_STREAMON: Resource temporarily unavailable

(cheese)

** (cheese:3230): WARNING **: Error starting streaming on device '/dev/video0'.
** (cheese:3230): WARNING **: Could not negotiate format

(uvcdynctrl)

harsh@ubuntu:~$ uvcdynctrl --list
Listing available devices:
  video0   HD Pro Webcam C920
  Media controller device /dev/media0 doesn't exist
ERROR: Unable to list device entities: Invalid device or device cannot be opened. (Code: 5)

(hwinfo)

harsh@ubuntu:~$hwinfo --usb
//specific to camera
06: USB 00.0: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_46d_82d_7AA010EF_if0_logicaldev_input
Unique ID: ADDn.nbyTPNaHH35
Parent ID: k4bc.Qnlx_VAX744
SysFS ID: /devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1/1-1:1.0
SysFS BusID: 1-1:1.0
Hardware Class: unknown
Model: "Logitech HD Pro Webcam C920"
Hotplug: USB
Vendor: usb 0x046d "Logitech, Inc."
Device: usb 0x082d "HD Pro Webcam C920"
Revision: "0.11"
Serial ID: "7AA010EF"
Driver: "uvcvideo"
Driver Modules: "uvcvideo"
Device File: /dev/input/event3
Device Files: /dev/input/event3, /dev/input/by-id/usb-046d_HD_Pro_Webcam_C920_7AA010EF-  event-if00, /dev/input/by-path/pci-0000:02:03.0-usb-0:1:1.0-event
Device Number: char 13:67
Speed: 480 Mbps
Module Alias: "usb:v046Dp082Dd0011dcEFdsc02dp01ic0Eisc01ip00in00"
Driver Info #0:
  Driver Status: uvcvideo is active
  Driver Activation Cmd: "modprobe uvcvideo"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #5 (Hub)

(v4l2-ctl)

harsh@ubuntu:~$ v4l2-ctl -D
Driver Info (not using libv4l2):
Driver name   : uvcvideo
Card type     : HD Pro Webcam C920
Bus info      : usb-0000:02:03.0-1
Driver version: 3.8.13
Capabilities  : 0x84000001
    Video Capture
    Streaming

(dmesg)

harsh@ubuntu:~$dmesg
[ 1978.311511] usb 1-1: USB disconnect, device number 2
[ 1982.231881] usb 1-1: new high-speed USB device number 3 using ehci-pci
[ 1982.541344] usb 1-1: New USB device found, idVendor=046d, idProduct=082d
[ 1982.541350] usb 1-1: New USB device strings: Mfr=0, Product=2, SerialNumber=1
[ 1982.541353] usb 1-1: Product: HD Pro Webcam C920
[ 1982.541356] usb 1-1: SerialNumber: 7AA010EF
[ 1982.547236] uvcvideo: Found UVC 1.00 device HD Pro Webcam C920 (046d:082d)
[ 1982.556504] input: HD Pro Webcam C920 as /devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1/1-1:1.0/input/input5

I have even tried the LD_PRELOAD solution as well, but same results. Would like any insight on this.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.