i copied eclipse and its files of code into a new comp.

i installed the latest version of java and went into eclipse.
i ran the porgram and the code that worked just fine on my previous computer compiled but the applet was blank
and it said "start: applet not initialized"
also the console had all sorts of red warnings and problems.

Maybe if you told us what the "warnings and problems" were then we could help. We're not mind readers.

also: what browser are you running it on. if you're using a new version of Chrome, for instance, it might be that applets are not longer supported.

most likely he's trying to run the applet in a browser but not hosted by a webserver.
That way lies madness.

you need a webserver in order for your applet to run and show. i suggest installing Apache Tomcat, it is best suited for java applets.

AndyJava: considering the statement that it worked perfectly on his previous pc, it's possible he's well aware how to run an applet.
It's better to wait for the OP to provide more context before keep guessing.