Hello,

I have a Activex exe, that makes use of multi threading. I have two PCs. A and B. When I run the program on A ( both in debug and compiled exe) it executes fine. I then created a package, installed it on PC B and the exe ran fine.

I did an upgrade on PC A, uninstalled it on B , copied and reinstalled on B, and now I cannot get the exe to work on B. If I run it in Debug mode on B it works fine.

I fails on the definition of the multi-thread class. Its properties are

DataBindingBehaviour = 0 vbNone
Instancing = 5 MultiUse
Persistance = 0 NotPersistable

The class consists of

Sub cProcessCD(Optr As Long, MainFormHandle As Long, wSource As String)
  Dim Frm As New frmProcessCD
  Load Frm
  Frm.lblSource.Caption = wSource
  Set Frm = Nothing
End Sub

Any help would be welcome

Regards
Mike

Are you sure it is properly registered in the registry?

Hi,

Thanks for the response. I have tried installing it on a different PC. I works no problem. I am currently re-installing windows XP on the PC that is giving me the problem. I did this because I suspected the registry was corrupted.

Regards
Mike

Cool, let me know if that fixes the problem...

Hi,

Everything seems to be ok on thenew PC, except I occasionally get a Run-time error '-2147287010 (8003001e)': Automation error. A disk error during read operation. This happens just as I try to creat my class. I cant seem to determine what is the cause as it does not happen all the time and is cured usually with a reboot.

Regards
Mike

This article has been dead for over six months. Start a new discussion instead.