I downloaded the installer for Visual C++ from the Microsoft website, and when I run it, I get this error message (below).

Help me!

Did the download complete?

Yes. It was an ~11MB download. I've tried redownloading about 5 times now, same error.

I think you are using the "Run" option instead of the "Save As" option from the Download Dialog Box. First Select "Save As" and store it on your Desktop or somewhere other than Temp. After the download completes, run the setup file.

Thanks for the suggestion, but that's what I've been doing all along. Firefox doesn't let me just "Run" the application, so I save it to my desktop and then run it. Same error.

Can you post the link/web page that you are downloading the file from?

You need to be connected to the net for it to work.

The 11mb is just the installer, which then downloads a couple hundred meg of the real thing.

You must have the .NET framework 2.0

>It was an ~11MB download

You think c++.net is just 11MB, boy are you in for a shock. LOL.

Hehe. I know that it's a lot more than 11 mb, but thanks about the .net framework -- I had to make a new user because my old one was corrupt on this pc. I'll install it now.

EDIT: Uhg same error when installing the .NET Framework 2.0. This account has admin privelages. What the heck is wrong?

Have you ever had previous versions (including betas) of visual studio on your pc?

On another account I had Visual Basic 2005 .NET, but I wiped the account about a week ago.

I think the problem has to do with your corrupt user account settings. The vcsetup.exe file which you downloaded extracts the setup file to the TEMP folder, but then it can't seem to find the path of the setup.exe file.

To check, Enter %USERPROFILE%\Local Settings\Temp in the Run Dialog Box (Windows Button + R ) and press enter. If it says that it can't find the path, then the settings for your temp folder is incorrect.

I think you can solve the problem by changing the location of the TEMP environment variable as follows.

  1. Click on the Start menu, choose Run and type sysdm.cpl
  2. Click on the Advanced tab and click the Environment Variables button at the bottom
  3. Double-click on the User variable named TEMP and change it to any path on your drive
  4. Double-click on the User variable named TMP and change it to any path on your drive
  5. Double-click on the System variable named TEMP and change it to any path on your drive
  6. Double-click on the System variable named TMP and change it to any path on your drive
  7. Click OK to officially change these environment variables