0

Hi All,

The following script checks whether the filename is correct then the script proceeds to check whether you have read,write and execute permisiions to the file and displays an approriate message.

#ss23
#usage ss23

echo "enter any filename \c"
read fname
if[!-z "$fname"] then
 if [-r $fname -a -w $fname -a -x $fname]
  then
    echo you have read,wirte and execute permisions to $fname
   else
    echo read,write and execute permisions denied
  fi
else

   echo improper filename
fi

when i run this script and give the filename 'test' it is showing the following error.

s23:line 3: if[!-z test]: command not found
s23:line 4: if [-r test -a -w $fname -a -x test] : command not found
s23:line 5:syntax error near unexpected token 'then'

i have seen this program in a shell scripting book and tried it but it has shown the above said error. '-z ' returns true if the lenght of the string is zero(this could be in Unix). what would be the equivalent command in Redhat linux. I am using Redhat llinux 9 version.

Please advice.

Thanks
Srini...

2
Contributors
1
Reply
2
Views
9 Years
Discussion Span
Last Post by radoulov
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.