I'm new to ASP.NET and using Visual Studio 2008 and also have installed IIS. But when I create a website in Visual Studio 2008 I tried to view in browser. When I do this in class I had no problems. But when I'm at home this message came up:

Server Error in '/Ch01_Practice' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The module was expected to contain an assembly manifest. (C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\web.config line 191)

Source Error:


Line 189: <add name="Profile" type="System.Web.Profile.ProfileModule"/>
Line 190: <add name="ErrorHandlerModule" type="System.Web.Mobile.ErrorHandlerModule, System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 191: <add name="ServiceModel" type="System.ServiceModel.Activation.HttpModule, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
Line 192: </httpModules>
Line 193: <mobileControls sessionStateHistorySize="6" cookielessDataDictionaryType="System.Web.Mobile.CookielessData">


Source File: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\web.config Line: 191


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433


Can anyone help me why this message came up? Help is appreciated. Thanks!

By the way, that's ASP.NET 2.0 :)

regardless, your web.config is set to work with the settings of the current machine. If you created it and it works on your class' machine, then you might have problems on another machine, and vice versa.

Anyway, change the Version number of line 191 to 2.0.0.0

This article has been dead for over six months. Start a new discussion instead.