Hello ALL:

New to the forum. I have run into a problem over the past 48 hours for which I can't seem to be able to resolve. I am running an Apache 2.0 Server, with PHP, and MySQL. All servers were working fine until 48 hours ago when all hell broke loose while evaluating a php software. Before the problem, PHP software could access MySQL databases; now whenever I attempt to run these software that once work, I get this error from one software. In other instances when I attempt to use other php software, I get an Internal Error 500. Of Note, php and mysql work independently, but a not talking to each other like before.
----------------------------------------------------------------------------------------------

This PHP environment doesn't have MySQL support built in. MySQL support is required if you want to use a MySQL database to run this forum. Consult the PHP documentation for further assistance.
----------------------------------------------------
I have reinstalled a fresh php.ini with similar values to the previous php.ini, but it does not resolve the problem. Also, when I try to run phpmyadmin, I get an error indicating:
----------------------------------------------------
cannot load mysqli extension,
please check PHP Configuration
Documentation
------------------------------------------------------

I have also edited the path in the environmental variables to no avail.

Can anyone shed light on how I can go about resolving this problem? I have read and read to no avial. Any insight will be appreciated. Thanks for your assistance in advance.

Rich.

try to create a php file include the following code in it.

<?php
phpinfo();
?>

and see if mysqli is enabled. if not check
be reminded to set the extension directory correctly
windows ex:
extension_dir = C:\php\ext
Linux ex
extension_dir = /etc/php/ext
In the php.ini remove the semicolon
;extension=php_mysqli.dll
to be
extension=php_mysqli.dll
also the
extension=php_mysql.dll
if you are using it.

there also might be a problem with Apache and that is a different story.
do these steps and come back to us

Edited 7 Years Ago by saadsaidi: forgot a semicolon :D

Comments
Look at the freaking date of the thread before replying. I doubt the OP is still having problems 2 years later.
This article has been dead for over six months. Start a new discussion instead.