Help. I can't get javascript to work on my computer at all. I've tried both Internet Explorer and Firefox but I either get messages saying that I need to enable it or install it, or the page just doesn't load. And I know that it isn't just the site I'm looking at because it's more than one site, and I checked to see whether it was working on different computers, which it is.

I have javascript enabled AND I have java installed, What am I meant to do??

If you know you have JavaScript enabled, say in Firefox
Tools > Options... > Content (tab) > Enable JavaScript (checkbox)
then it sounds like you have a system-level problem, possibly a virus (?).

Try reinstalling your main browser (hopefully Firefox) and if that doesn't do the trick, either get virus removal software or reinstall your operating system.

Good luck

I tried reinstalling Firefox, but that did nothing except take up time.

If it is a virus could it have something to do with all of the dumb messages I get when logging on to my computer??

Ummn, you should have mentioned the dumb message you get when logging onto your computer :-) How do you spell v.i.r.u.s.

... good luck

Well excuse me for not believing in there being a way to fix all my problems at once

Hey, relax, I was being facetious -- I wasn't trying to be snide.

I don't know for sure you have a virus but it does seem likely from what you are describing -- and I'm sorry if you do, it's a real pain sometimes.

I actually spent a week with my computer down recently since I kicked the power plug out while it was thinking about something that must have been important, since it wouldn't work after that -- I tried everything I could find, believe me. I finally had to reformat and rebuild it from scratch.

I would get a decent virus software and see what that can do, you might download one as a demo version and if it finds the problem then that would be a good one to buy for ongoing protection.

Good luck

Ok.

Ummmm I ran several virus/spyware scans over the the last couple of days, scanning every inch of my computer with Zonealarm. It found a handful of viruses and spyware threats, which have now been dealt with. And I stopped soon of the messages at log on by changing the settings on my computer so that they wouldn't run. But I'm still having problems with javascripts.

Is there anyway to fix it without reinstalling windows??

By the way, I tried reinstalling java but all it seems to have done is waste time.

Okay, I did some Googling about on your behalf and it seems that some people were experiencing a similar situation after installing MS Windows Updates on their computers.

If you might have installed updates prior to noticing JavaScript not working, you might roll-back those updates and see if that helps the situation any...

Best of luck

As far as I know I haven't installed any updates for Windows, and doubt I can as I have an illegal version of Windows installed on my computer.

I'll check whether there any updates to roll back though, and I'll try the different browser idea too.

I couldn't find any updates to roll back (hope I was looking in the right place), and i tried to download a different browser but i was unable to download it with my computer, i kept getting an error message saying 'object blocked' instead. Could this have to do with the javascript problems?

Ok. So I've been reading around about other peoples problems with web browsers and javascripts that are similar to mine and heard that booting up in safe mode with networking support sometimes fixes the problem. So I tried that, and now I can download stuff and view javascript webs in the safe mode. Any points as to where I'm meant to go from here?

Okay. So I've been thinking that maybe this has something to do with parts of old spyware that has been removed by zonealarm. Those hackers are after me again. Lol :D

So anyway, I went and downloaded HijackThis, cause I heard it was good for problems similar to this.

Here's the log for normal mode:

Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 4:45:23 PM, on 20/09/2008
Platform: Windows XP (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 (6.00.2600.0000)
Boot mode: Normal

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\ZoneLabs\vsmon.exe
C:\WINDOWS\system32\spoolsv.exe
C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
C:\WINDOWS\Explorer.EXE
C:\Program Files\Media Players\iTunes\iTunesHelper.exe
C:\Program Files\Common Files\Real\Update_OB\realsched.exe
C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe
C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe
C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe
C:\Program Files\iPod\bin\iPodService.exe
C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe
C:\Program Files\GetPack\GetPack21.exe
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe
C:\PROGRA~1\ZONELA~1\ZONEAL~1\MAILFR~1\mantispm.exe

O2 - BHO: {9cc6eae8-1b5a-285a-d204-520c2c8abb62} - {26bba8c2-c025-402d-a582-a5b18eae6cc9} - (no file)
O2 - BHO: (no name) - {29842243-5CB1-43CA-AB63-EC691F708541} - (no file)
O2 - BHO: Helper Class - {3670A914-63C2-4E67-8C9B-370AE1922143} - C:\Program Files\BChanger\bchanger.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O2 - BHO: QXK Olive - {79800AD8-CFDD-4F0F-B0CA-A136F04D90D9} - (no file)
O2 - BHO: DrFlex IE Helper - {8EEB2711-9D21-4f9c-99A1-B7FC5A8CA56A} - C:\Program Files\QdrDrive\QdrDrive20.dll
O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\3.0.1225.9868\swg.dll
O2 - BHO: (no name) - {C0151AFE-C4FC-43FA-A2DC-AA8B9E046308} - (no file)
O2 - BHO: banneradsgalore browser optimizer - {c1080842-7c34-9250-3481-fbe56618d1ce} - (no file)
O2 - BHO: Megaupload Toolbar - {EEE17712-987E-4424-A00C-9DA0BC4E2078} - (no file)
O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\QTTask.exe" -atboottime
O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\Media Players\iTunes\iTunesHelper.exe"
O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot
O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"
O4 - HKLM\..\Run: [ZoneAlarm Client] "C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe"
O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe"
O4 - HKCU\..\Run: [swg] C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe
O4 - HKCU\..\Run: [VnrPack20] "C:\Program Files\VnrPack\VnrPack20.exe"
O4 - HKCU\..\Run: [VnrBlock20] "C:\Program Files\VnrBlock\VnrBlock20.exe"
O4 - HKCU\..\Run: [GetPack21] "C:\Program Files\GetPack\GetPack21.exe"
O4 - HKCU\..\Policies\Explorer\Run: [NT Printing Services] ftps.exe
O4 - HKCU\..\Policies\Explorer\Run: [Windows Printing Driver] gpedits.exe
O4 - HKUS\S-1-5-19\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-20\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'Default user')
O8 - Extra context menu item: Add to Google Photos Screensa&ver - res://C:\WINDOWS\System32\GPhotos.scr/200
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL
O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://www.update.microsoft.com/windowsupdate/v6/V5Controls/en/x86/client/wuweb_site.cab?1217660274330
O21 - SSODL: eqvwamkl - {498F29C9-AD23-41C0-8946-1D710BF7E0CF} - (no file)
O23 - Service: Google Updater Service (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: TrueVector Internet Monitor (vsmon) - Zone Labs, LLC - C:\WINDOWS\system32\ZoneLabs\vsmon.exe

--
End of file - 4968 bytes

And here's the one for safe mode:

Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 9:38:34 AM, on 19/09/2008
Platform: Windows XP (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 (6.00.2600.0000)
Boot mode: Safe mode with network support

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\Explorer.EXE
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

O2 - BHO: {9cc6eae8-1b5a-285a-d204-520c2c8abb62} - {26bba8c2-c025-402d-a582-a5b18eae6cc9} - (no file)
O2 - BHO: (no name) - {29842243-5CB1-43CA-AB63-EC691F708541} - (no file)
O2 - BHO: Helper Class - {3670A914-63C2-4E67-8C9B-370AE1922143} - C:\Program Files\BChanger\bchanger.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O2 - BHO: QXK Olive - {79800AD8-CFDD-4F0F-B0CA-A136F04D90D9} - (no file)
O2 - BHO: DrFlex IE Helper - {8EEB2711-9D21-4f9c-99A1-B7FC5A8CA56A} - C:\Program Files\QdrDrive\QdrDrive20.dll
O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\3.0.1225.9868\swg.dll
O2 - BHO: (no name) - {C0151AFE-C4FC-43FA-A2DC-AA8B9E046308} - (no file)
O2 - BHO: banneradsgalore browser optimizer - {c1080842-7c34-9250-3481-fbe56618d1ce} - (no file)
O2 - BHO: Megaupload Toolbar - {EEE17712-987E-4424-A00C-9DA0BC4E2078} - (no file)
O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\QTTask.exe" -atboottime
O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\Media Players\iTunes\iTunesHelper.exe"
O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot
O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"
O4 - HKLM\..\Run: [ZoneAlarm Client] "C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe"
O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe"
O4 - HKCU\..\Run: [swg] C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe
O4 - HKCU\..\Run: [VnrPack20] "C:\Program Files\VnrPack\VnrPack20.exe"
O4 - HKCU\..\Run: [VnrBlock20] "C:\Program Files\VnrBlock\VnrBlock20.exe"
O4 - HKCU\..\Run: [GetPack21] "C:\Program Files\GetPack\GetPack21.exe"
O4 - HKCU\..\Policies\Explorer\Run: [NT Printing Services] ftps.exe
O4 - HKCU\..\Policies\Explorer\Run: [Windows Printing Driver] gpedits.exe
O4 - HKUS\S-1-5-19\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-20\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'Default user')
O8 - Extra context menu item: Add to Google Photos Screensa&ver - res://C:\WINDOWS\System32\GPhotos.scr/200
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL
O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://www.update.microsoft.com/windowsupdate/v6/V5Controls/en/x86/client/wuweb_site.cab?1217660274330
O21 - SSODL: eqvwamkl - {498F29C9-AD23-41C0-8946-1D710BF7E0CF} - (no file)
O23 - Service: Google Updater Service (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: TrueVector Internet Monitor (vsmon) - Zone Labs, LLC - C:\WINDOWS\system32\ZoneLabs\vsmon.exe

--
End of file - 4364 bytes

I'm not sure what half of this stuff means, but hopefully you guys do, or somebody does, and can point me to what I need to do to fix my problem.

Also there is a ftp folder that pops up when I login in normal mode, which used to pop up with an error message which I have so how managed to stop, but the folder still opens upon login.

I am having the same issue. Windows Vista, latest Avira Antivirus running looks good, but no javascript in any browser (error shown in IE8) no errors but just no output/interaction in FF and Chrome. At a loss...

no javascript in any browser (error shown in IE8)

Save this

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
  <head>
    <meta name="generator" content=
    "HTML Tidy for Windows (vers 25 March 2009), see www.w3.org">
    <script type="text/javascript">
alert('hello')
    </script>
    <title></title>
  </head>
  <body>
  </body>
</html>

to your desktop as an .html file and open it in any browser.

What, if anything, happens?

Edited 6 Years Ago by fxm: n/a

Save this <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
save this [...]
What, if anything, happens?

Hi, I have a similar issue with my WinXP (SP3, Java 6.21, Symantec Endpoint Protection). I thought that JScript would not work at all because I do not get JScript popups like on this site for instance:

http://career.daimler.com/dhr/job.php?jid=069851

(sorry for german, but clicking on the links should open up a window with the job description)

This did work about 1 week ago in IE7, Chrome 5.0.357.126, Firefox portable 3.6.3 , OperaUSB 10.50. Your script though produces a popup window with "hello" in all of them. So, JavaScript is working - but not fully. However, since it is on all those browsers it still must be some kind of system level issue - not browser level.

Strange...

Edited 3 Years Ago by mike_2000_17: Fixed formatting

AM HAVING THE SAME PROBLEM WITH ALL MY BROWSERS WHAT SEEMS TO BE THE ACTUAL PROBLEM

Not helpful. Describe your issue clearly. Which AV software are you running? Do you get the popups as described above. Can you get a simple alert message to run. Have you enabled javascript on each browser? Is this a works machine, where a blanket policy turns off all JS? The list goes on...

it was currently working and all over a sudden it stopped working i have checked all the browsers and it is enabled. i get no popus on any thing even when i tried to run a simple code with jave one it just display the hello word it does not work

hpox, "does not work" is not a clear definition of a problem.
Did you open the developer console? Does it show any errors?
Only local page doesn't work or any page? Did you check internet security options?

@hpox
1.what were you doing before things started going south?
2.did you visit a site requesting you to install JAVA engine?
3.what is your current OS?

am using windows 8.1 and no i never visited any site was simply doin some simple java coding

This article has been dead for over six months. Start a new discussion instead.