hey frnds, I m new to the ASP.net..Plz jelp me out.

My windows is Installed in D:

I made project & save it D:\Inetpub\wwwroot\WebSite1
Website1 is the folder I created & form name is aspx.

<%@ Page Language="VB" %>



<html >
<head>
    <title>Introduction</title>
</head>
<body>
<%  Response.Write("My First project")%>
   </body>
</html>

I Run it as http://localhost/website1/default.aspx--But the error is coming.can somebody help me out

you are missing your form tag, also it is not good idea to hand code aspx pages. try visual web developer/

i have to disagree here, why is it bad to hand code aspx pages? just wondering as there are many programmers/developers that program in the most basic of all programs "notepad" for HTML, CSS, Javascript, php, Java and many other languages

Using an IDE simply makes it faster to develop but doesnt at all make the process of learning the language any easier.

i have to disagree here, why is it bad to hand code aspx pages? just wondering as there are many programmers/developers that program in the most basic of all programs "notepad" for HTML, CSS, Javascript, php, Java and many other languages

Using an IDE simply makes it faster to develop but doesnt at all make the process of learning the language any easier.

further to this im sorry i didnt answer your question.

If you did build this site in visual studio or an IDE then using the RUN command will run your website. I understand if you wish to set this up manually though you will need to tamper with your IIS.

You have created your directory below "wwwroot" so all you need to do is open "Control Panel >> Administrative Tools >> Internet Information Services [version no.]" then in the tree on the left navigate to the "Default Website". Expand this node and you will see your folder "Website1", right click and choose "Convert To Application", now run your url and if everthing is setup fine it will work.

If you receieve an error stating the server does not know how to handle the file type "aspx" you will need to open "Control Panel >> All Programs" then press "Add Remove Windows Features", you will need to navigate to "Internet Information Services >> World Wide Web Services" and then make sure the following are checked.
> .NET Extensibility
> ASP.NET
> ISAPI Extensions
> ISAPI Filters

Hope this helps

Hi frnd,there is no Administrative Tools option in Control Panel..Can u plz confirm me out...

what operating system and setup are you using ?

Hey frnds, I m able to acess the admin tools. My website name is sonia.
I open admin tools & right click on folder sonia but hi fungus there is no custom menu "Convert To Application" . U can see it in the attachment.....

Attachments Sonia.JPG 82.37 KB

Hey frnds, I m able to acess the admin tools. My website name is sonia.
I open admin tools & right click on folder sonia but hi fungus there is no custom menu "Convert To Application" . U can see it in the attachment.....

The days of IIS 5.1, beautiful. Im guessing here but have you looked under all tasks sub context menu ? Not having XP or IIS 5.1 anymore (Since 2006) i really cannot remember exactly where this is found although you dont seem to have ASP.NET installed as you should have an "aspnet_client" folder under the "Default Website"

You need to go to the add ASP.NET as a sub component of the IIS in add/remove programs on the control panel.

This question has already been answered. Start a new discussion instead.