0

Hi,

I am wondering if anyone here has ever attempted to connect to the oracle 10g xe database from visual web developer? I have been trying to do this all day, however it is starting to get really irratating! I have downloaded the oracle dataacess dll, and imported it into my application, however I am not sure what to enter as the server name when using the configure data source wizard in VWD. Anyone any ideas?

I have tried using XE, and username/password as hr/hr, however I am getting the error "TNS: could not resolve the connect identifier specified".

I am starting to doubt if it is actually possible to connect to this database using oracle xe. Any ideas at all would be most appreciated!

Regards,

David.

4
Contributors
3
Replies
4
Views
7 Years
Discussion Span
Last Post by __avd
0

David,

Hopefully you have solved the problem in 3 months (Google found your post). This is what I figured out today - maybe it will help you or someone else:
* In the Start Menu click:
Oracle Database 10g Express Edition=>Go To Database Home Page
* Log in (hr worked for me).
* Click the Administration icon.
* Click the About Database icon. This made me login as "system".
* Check the CGI Environment checkbox.
* Click Go.
* Under the CGI Environment heading, use the value of PLSQL_GATEWAY. This is "WebDb" on my computer.

I managed to trade an unresolved identifier error for a timeout error, but I suspect I'm making progress. I may have disabled too many Oracle services for the sake of security.

Mike

0

If you are trying to connect through ASP.NET or C#, then you should be able to connect it using OleDBConnection with the MSDAOSA provider.

0

mcgarry101,
Add a reference of System.Data.OracleClient.DLL into your application.
>TNS: could not resolve the connect identifier specified.
It's name of server (listener) - Try name of computer.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.