Maybe I've just missed this one and its easy .. but I like to write my local css styles using a single line .. But everytime I drag a control onto the web page VS creates the .Style1, .Style2 etc etc. Trash to clean up. If I DO clean it up and assign the style to a control with the style a single line ... then later move the control, VS re-arranges the style into multiple lines for (gee thanks)... Can this behaviour be turned off ... I'd also like to control the ORDER of the attributes.. asking for too much? See before and after below...

before...

.lblLogin       {left:14px;top:95px;position:absolute}
    .lblPassword    {left:14px;top:128px;position:absolute}

after I move the label in designer

.lblLogin       {left:28px;
top:86px;
position:absolute
        }
    .lblPassword    {left:14px;top:128px;position:absolute}

You can control the code editor's behavior by going to "Tools -- Options" then on the left expand "Text Editor", then CSS, then select "Format". Change the format style to "Compact Rules". I have attached a screenshot of how to change the setting.

Attachments environment.png 14.22 KB
This question has already been answered. Start a new discussion instead.