Hello everyone,

I'm trying to test PHP of WAMP on a vista machine but every time I attempt to launch a page in IE, the browser asks if I want to download the PHP page. Here is the code I've used:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Test</title>
</head>

<body>
            <? php
                phpinfo();
            ?>
</body>
</html>

I've also attempted a simple echo of get world and see the same behavior. I feel like there is something very simple I have forgotten. Windows firewall is off.

This is because of your apache web server is not configured properly.

You should look at the httpd.conf file for apache and change its default port to 8080 if IIS is running on your machine. As IIS runs on 80 port that could stop apache to occupy its port.


Hello everyone,

I'm trying to test PHP of WAMP on a vista machine but every time I attempt to launch a page in IE, the browser asks if I want to download the PHP page. Here is the code I've used:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Test</title>
</head>

<body>
            <? php
                phpinfo();
            ?>
</body>
</html>

I've also attempted a simple echo of get world and see the same behavior. I feel like there is something very simple I have forgotten. Windows firewall is off.

This is because of your apache web server is not configured properly.

You should look at the httpd.conf file for apache and change its default port to 8080 if IIS is running on your machine. As IIS runs on 80 port that could stop apache to occupy its port.

Hey Kamran! I appreciate your suggestion, this has not changed my situation. I attempted to clear temporary files and cache and try to re run the page. I change the getinfo() to an echo with Hello World as my output: <?php echo("Hello World"); ?> .

The only notable difference at this point is that I need to include a port number in the browser when navigating to WAMPServer home.

Do you have any additional suggestions?

do you have skype running?

No, I do have skype and when it runs, I am not able to access the localhost/WAMP server page; however, this was aproblem before that I alleviated by just not running skype.

make sure skype is off before you run wamp!

Thank you,

It is off.

Hello,

Try to test wamp on different port to find out if port is being used by different application or blocked by your isp.

Open file httpd.conf and find this line

listen 80
Change to
listen 81

Save file and restart wamp to take effect. Remember to enable port 81 in all firewalls and routers as well ;-)

If my post help you, do add it to my reputation.

This article has been dead for over six months. Start a new discussion instead.