Hello,
I am using spaw editor.Till now i think it is the one of the best editor.But i m now facing 1 problem.Suppose we left editor as empty.then switch tab to html view.then we see a <br /> tag by default.So is there any way to remove this <br /> tag either from spaw side or any programming logic.

Pls pls help me out.I have even read the spaw documentation but could not able to find any solu:S tion.

I think some of you missed the point, Spaw2 is an online editor, unlike Notepad++ etc, much like TinyMCE and FCKEditor I agree with borntowin - it's beautiful - especially as the filemanager plugin is free (unlike the others mentioned). Must say, I haven't noticed the <br /> problem myself and have used it extensively. I will have a little look to find out. By the way, are you using the latest version (pHp)?

Yes I am using latest version.Actually i want to know is there any settings in config from where we can have control on this.
For timebeing I have solved this problem using externally.

preg_replace('{^(<br(\s*/)?>|ANDnbsp; )+}i', '', $string);

This will replace only the first <br /> and nbsp; from the string.I find this useful because of my situational requirement.But still i would like to know is there any way to solve this problem by using spaw editor config/any other settings?:-/

This article has been dead for over six months. Start a new discussion instead.