0

Hello All,
First – I apologize if this is not the correct group – the asp groups seem to have a very low activity rate, so I decided to give this a try here.
Whenever I try and run/debug my ASP.NET application, I receive the warning that “You do not have permissions to Debug the Server. Verify that you are a member of the Debugger users group on the server”.
Some times I get the warning “This project is not configured to be debugged”
The problem is, I believe that I am member of this group. I have opened up the project config file and debug is set to YES.
IIS was installed AFTER VS.NET, so I ran the .NET repair described in help, by reinserting my VS disc and running from the command line:
D:\dotNetFramework\dotnetfx.exe /t:c:\temp /c:"msiexec.exe /fvecms c:\temp\netfx.msi"

Windows XP SP3
.NET versions 1.1, 2, 3, and 3.5 installed on machine
Visual Studio.NET 2003

Administrative Tools > Internet Information Services > Web Sites > Default Web Site > Right Click “Properties” >

Directory Security Tab:
• Anonymous Access = Y
o UserName = Device\User
o Allow IIS to control Password = Y
• Integrated Windows Authentication = Y

Home Directory Tab :
• When connecting to the resource, the content should come from
o A directory on this computer
• Local Path : c:\inetpub\www.root
• Application Name : Default Application
• Execute Permissions : Scripts and Executables
• Application Protection : Medium (Pooled)
• True :
o Script Source Acess
o Read
o Write
o Directory Browsing
o Log Visits
o Index This Resource

Configuration from Home Directory Tab
Enable ASP Server Side Debugging set to TRUE
ASP.NET Tab :
IF set to Version 1.1.4322, the web.config path is set to \inetpub\www.root.
Edit Configuration is button inactivated

If set to Version 2.0.50727, I can Edit the config file.
o Editing Config File > Application Tab > Debugging = True

Can someone please help? Im at wits end here as to how to get this running and debugging.
Thanks in advance for any help or advice given,
Sean

2
Contributors
5
Replies
6
Views
8 Years
Discussion Span
Last Post by seanmc23
0

Start -- Settings -- Control Panel -- Computer Management -- System Tools -- Local Users and groups -- Users -- <locate your user> -- check the "Member Of" tab to see if you're in the debugger group or the administrator group.

Also are you logging on the machine locally or through the domain? I'm not sure if you need rights on the domain for local debugging. I would think not but it wouldn't surprise me.

0

Start -- Settings -- Control Panel -- Computer Management -- System Tools -- Local Users and groups -- Users -- <locate your user> -- check the "Member Of" tab to see if you're in the debugger group or the administrator group.

Also are you logging on the machine locally or through the domain? I'm not sure if you need rights on the domain for local debugging. I would think not but it wouldn't surprise me.

Hi Scott,
Thanks you for your reply.
I have added my User Name to the Debugger Users, Power Users, and VS Developers Groups, as well as originally being in the Administrators group.
It seems that the warning I am receiving most often is that this Project is not configured for debugging, even though the web.config file says debug = true.
Local Machine, home network with no Domain, is what I am working on.
Thank You ,
Sean

0

I don't know what else to say. Take a look at your windows event logs and see if something is throwing errors. Usually VS tells you what to fix if something is wrong for you debug. Take screenshots of the errors by hitting ALT+PRINT SCREEN while the error dialog is focused and post them up here.

[edit]
Your event logs can be found by "Start -- Run" and typing "eventvwr"
There is also an icon in your administrative tools.
[/edit]

Edited by sknake: n/a

0

I don't know what else to say. Take a look at your windows event logs and see if something is throwing errors. Usually VS tells you what to fix if something is wrong for you debug. Take screenshots of the errors by hitting ALT+PRINT SCREEN while the error dialog is focused and post them up here.

[edit]
Your event logs can be found by "Start -- Run" and typing "eventvwr"
There is also an icon in your administrative tools.
[/edit]

--------------------------------------------------------------------------------------

Thanks Scott– the error log is a new trick I haven’t run across yet.
I tried debugging my project, and immediately thereafter checked the error log :

First Event under the System Header :
Date ………………….Source : Service Control Manger
Time …………………Category : None
Type: Information Event Id : 7035
User : NT AUTHORITY/SYSTEM
Computer : ……

Description :
The Com+ System Application service was successfully sent a start control
Event 2 (and final under the System Header) :
Date ………………….Source : Service Control Manger
Time …………………Category : None
Type: Information Event Id : 7035
User : N/A
Computer : ……

Description :
The Com+ System Application service entered the running state

First Event under the Application Header:
Date ………………….Source: Service Control Manger
Time …………………Category: Web Event
Type: Warning Event Id: 1310
User: N /A
Computer: My Computer Name

Description :
Event Code: 3008
Event Message: A Configuration Error has occurred
Event Time : …
Event code: 3008
Event message: A configuration error has occurred.
Event time: 9/20/2009 7:53:06 AM
Event time (UTC): 9/20/2009 11:53:06 AM
Event ID: 22bb0f520d5f4753b0c110fa5442e5d4 Event sequence: 1
Event occurrence: 1
Event detail code: 0

Application information:
Application domain: /LM/w3svc/1/root/WebApplication2-1-128979211865468750
Trust level: Full
Application Virtual Path: /WebApplication2
Application Path: c:\inetpub\wwwroot\WebApplication2\
Machine name: MOBILE1

Process information:
Process ID: 1760
Process name: aspnet_wp.exe
Account name: MOBILE1\ASPNET

Exception information:
Exception type: ConfigurationErrorsException
Exception message: It is an error to use a section registered as allowDefinition='MachineToWebRoot' beyond the root web.config file. (c:\inetpub\wwwroot\web.config line 297)
Request information:
Request URL: http://localhost/WebApplication2/get_aspx_ver.aspx
Request path: /WebApplication2/get_aspx_ver.aspx
User host address: 127.0.0.1
User:
Is authenticated: False
Authentication Type:
Thread account name: MOBILE1\ASPNET

Thread information:
Thread ID: 1
Thread account name: MOBILE1\ASPNET
Is impersonating: False
Stack trace: at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)

Custom event details:

Follows is the Error Page Displayed for site on this Application error:

Server Error in '/WebApplication2' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToWebRoot' beyond the root web.config file.

Source Error:


Line 295: </pages>
Line 296:
Line 297: <protocols/>
Line 298:
Line 299: <siteMap>


Source File: c:\inetpub\wwwroot\web.config Line: 297


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082


~Sean

Edited by seanmc23: n/a

0

HI Again Scott,

Concerning the above posted errors :

When I first started having this problem, I noticed that in :

Administrative Tools > Internet Information Services > Web Sites > Default Web Site > Right Click “Properties” > ASP.NET > Version Drop Down

If I selected V1.1...., the path to web.config was in the wwwroot folder, where there was no file. So I went to the C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG folder, and copied it into wwwroot to see what happened. The above errors I believe were from this file, because when I removed the lines specified in the log errors, I stopped recieving ANY log errors from my debuggin attempts.

So in short, I am no longer recieving any log errors, but, I am still recieving the “You do not have permissions to Debug the Server. Verify that you are a member of the Debugger users group on the server” message from VS.

Could this possibly be because of the other versions of the .NET framework running on my PC, when VS2003 wants 1.1?
As I said earlier, when I choose v1.1 in my web properties, the edit Config File option gets inactivated - this appears to be because there is no config file in the Framework 1.1 folder, and the only config file in wwwroot is the one copied from Framework 2.0 folder. (Im guessing)

~Sean

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.