0

Hi all,

I've searched for this problem in several forums, and as I couldn't find it in any of them, I decided to start this thread. I am a magnet for weird problems.

There's this groupware webapplication that I want to test, and for that, I put it on my own personal domain using FileZilla. From there on, I had to install the application on my domain, which in part entails making some directories outside of the document root with 777 permissions. Each time I do that, and in whatever directory I put the directories, the application install can't seem to find them.

What's more striking, is what happened after I changed the permissions of all files and directories of said web application to 777, just as a test. After that, my browser rewarded me with a "The requested URL /works/trunk-clean/www/install was not found on this server." message whenever I entered some directory or file of the web application in my browser.

I'll try to locally change the permissions of the directory before uploading it again and see what happens then, but still... this is weird, isn't it? Any ideas?

There's this other thing that may be related to the above problem. If I tell FileZilla to delete the entire directory of the web application, it says repeatedly and for every subdirectory, among others, "550 Remove directory operation failed," and the directories remain on the FileZilla GUI. What's up with that?

[EDIT :] Well I did that last option, but I get similar results. The only difference is, when I copy the directories into the web application directory, and then do chmod 777 on them, I get a 403 error when I try to access them by typing the URL into the browser. So after FileZilla does a 777 on the directories (and the FileZilla GUI's directory listing says that went well), my browser greets me by saying I don't have enough permissions to access that directory "on this server". What?

Can anyone please help me on this one? I'm afraid it may take days before I can make any progress with my work because of this...

Cheers,
Wilmar.

2
Contributors
2
Replies
3
Views
7 Years
Discussion Span
Last Post by Wilmar1980
0

I can't quite tell whether this is the reason, but you need to ensure that not only are the permissions set on the end directory, but also (at minimum) execute permissions on all the parent directories required to traverse to that directory.

In other words, suppose I'm in /one/two/three and I want to write to /three/blind/mice, not only do I need to specify write permissions on "mice", but also a minimum of 111 permissions on "three" and "blind". Otherwise I can't navigate to "mice".

I would try setting 711 on all parent directories of the target directory.

0

Thank you so much for responding. I'm completely flabbergasted right now, so I could use all the alternative options I can get.

Your solution is a plausible one, were it not that at the moment I have 777 subdirectories (which I want to access but can't due to 403 error) in 755 directories (which I can access).

Cheers,
Wilmar.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.