0

Hi.to all
This is Amit..
i have one website in which i m using (html,aspx) pages.
i uploaded also to my domain.
HTML pages works properly but when i request for ASPX page it shows :::::::::::::::::::
------------------------------------------------------------------------------------
"Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off"."
-----------------------------------------------------------------------------------
after this i changed my web config file and set the custom error mode="remoteonly" and defaultUrl="MyCustomerror.html" then i build it and Publish it once again and upload it again to server.
when i again equest for aspx page it will redirect me to MyCustomerror.html..
so how can i request for aspx page..and this is just a normal wellcome page of aspx No database, No server side coding i used in this page..if this problem solved then i can think about database creation..into my domain..
please help me in this topic..
eagarly waiting for anybudy's reply..

Thanks..
Amit

Edited by amitshrivas: n/a

3
Contributors
6
Replies
7
Views
7 Years
Discussion Span
Last Post by amitshrivas
0

Did you try this and did not work?
"<customErrors> tag should then have its "mode" attribute set to "Off".""
<customErrors mode="Off" />

0

Did you try this and did not work?
"<customErrors> tag should then have its "mode" attribute set to "Off".""
<customErrors mode="Off" />

if i set CustomError mode="off" then it will give me Parser Exception
and if i set CustomError mode="remoteOnly"|"On" then it will redirect me to MyCustomError.htm page
dont show the aspx page

0

it seems like a problem in your web.config leave your custom error set to off and then copy and pase all your web.config content into a notepad and save the document as xml, try to browse the xml file in the browser. If the xml file is unable to be rendered by the browser and throws some errors, then you can find the place where the tags are not well formed and fix them. also remember that web.config is case sensitive.

0

I copy the code of xml and save it by .xml and run it in IE .it runs ok,showing no error what would be the problem sir. and
i m new to Dani web IT Community. so can u tell me the rules of what to right and what not in easy way..
plzz coz i got warning from Dani WEb community.. :(

0

>i m new to Dani web IT Community. so can u tell me the rules of what to right and what not in easy way..


Please read before posting - http://www.daniweb.com/forums/thread78223.html and http://www.daniweb.com/forums/faq.php?faq=daniweb_policies

------------------
Hi..again
i uploaded a aspx page succusfully and its running now..
but my next problem is related with database..
i created database in Live server and after that i run it .
its running but it will take me to custompage.html again..
may be my configuration to web.config file is wrong..
what would be the standard configfuration ..

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.