0

Hi,

I just started a free trial with a new webhost as my current one is useless.

I have always had my website working on the old webhost fine.

I have a folder called sessions outside the public_html folder so it cannot be accessed in a browser and not accessed by anyone else as i am on a shared host.

With my previous host everytime i logged in to my own website i could edit the session file and see all the users data in there. For some reason on my new webhost when i login and try and view the session data in the session file all i see is one very long random string.

Problem is i don't know why this is happening, i see no user data in there just a long random string. It is causing my website problems as for example, when i login the main control panel page shows my name which is stored in the session which is good but when i go to edit profile page no data is being shown in the form boxes from the session, just blank jet on my old host it shows data like it should.

another problem is the view profile webpage is also repeating the user data, again strange as it is coming from session yet for example instead of showing the username once it is showing it multiple times (repeating iteself).

As i say my site has never gave me problems on old webhost.

Could anyone shed any light on this please?

1) Confused why session file has a random string and not users data in there, i can only think of there is some feature on there server that serializes the data in the session files, althou i have never heard of this.

2) It displays my name fine on main control panel page but on edit profile no data is shown from session in the form boxes.

3) view own user profile shows users data from session but is repeating the data.

Thanks for any help.

1
Contributor
2
Replies
3
Views
7 Years
Discussion Span
Last Post by genieuk
0

mmmm,

I just switched the PHP version from 5 to 4 in control panel and it now works fine althou the session data is still a random string.

Thing is i use php 5 on old web host. I can only think there must be a configuration setting in the php.ini file which i don't have access to.

But if anyone could explain or know any reason that would be great as i rather know before trying another webhost. I want to stick to PHP 5 not 4.

Thankfully i had a free 14 day trial which started yesterday.

There support does not seem to have a clue, all they said was ask another developer :O

Edited by genieuk: n/a

0

I figured it.

They had register_globabls on so i asked them to give me a copy of the php.ini file so i can edit and change things myself.

Can you beleive they told me that they cannot turn it off for me. Reason why is i now have to place the php.ini file in every folder etc, plus register_globals should be off by default anyway due to the security issues that come with it.

Thanks

Edited by genieuk: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.