0

I'm not really sure what's going on. I've looked all over the internet and have been stuck on this issue for days. It seems as though few have run into this problem and those that have - have no suggestions or even any replies. CKEditor's help forum has nothing on this issue, either.

I'm using php5 and an array of ckeditor objects. It's as simple as

$editor = new CKEditor();
$editor->editor('text_area_values['.$counter.']', $data[$meta->name]);

Basically what the above is doing is getting the value of a column in a db and dumping it into the value of each ckeditor object. This code works fine both locally and on a hosted godaddy.com server. I can do anything to ckeditor as needed, and have gone pretty far into a lot of the config and core files. It's very straight forward.

The problem I'm running into is on another hosted godaddy.com server - ckeditor doesn't show up under any circumstance. It just dies and a text area is rendered with the data from its respective db column. I have no idea what's causing this to happen, as I'm using the same exact code, same exact site actually, I exported a sql file from the problematic site and imported into the db on the other 2 sites so db data is exactly the same on all 3 servers, and 2 of the 3 are coming out perfectly. Only one won't render ckeditor.

I also tried rendering ckeditor with no values at all - setting the default value of each editor in the array to '' and still nothing.

I thought maybe it was a bad file upload somewhere in ckeditor, so I've uploaded not only ckeditor but the entire site several times as well, and still only a textarea displays. This leads me to believe it's something that the server itself is possibly doing to prevent ckeditor from displaying properly. So I decided to dump the ckeditor object and see what I get - and when I dump the ckeditor object I get this:

CKEditor Object
(
    [basePath] => 
    [config] => Array
        (
        )

    [initialized] => 1
    [returnOutput] => 
    [textareaAttributes] => Array
        (
            [rows] => 8
            [cols] => 60
        )

    [timestamp] => AA4E4NT
    [events:private] => Array
        (
        )

    [globalEvents:private] => Array
        (
        )

)

I've noticed returnOutput doesn't have a value. I believe its default value is false, and for what I'm doing it should be, because I'm not assigning any ckeditor methods to variables. Just for kicks, I did set it to true and the value did not show, either - so I'm not sure if that is a red flag or not.

I'm honestly stumped on this one though. Does anyone have any ideas, suggestions, or experience(s) with this problem? Any help is greatly appreciated.

2
Contributors
2
Replies
3
Views
6 Years
Discussion Span
Last Post by sleign
0

Did you upload all files required? And did you include the javascript on top to get ckEditor loaded?

Are your variables all the same? (caps sensitive)
Are you sure your database works fine? (passwords have not changed?)

Can you see the error log of the server? This might show you a good error...

Edited by ShArKsss: n/a

0

the server log showed that ckeditor.js was missing. I noticed it was pointing to the wrong directory - the file was there. ckeditor has a method that changes where to look for itself. default has always worked in the past so I never used it, but I used it in this case to point to the correct location of ckeditor on the server and it came up immediately. everything works beautifully now - thanks for the tip :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.