hi,

I need help in installing gd library with php4.3.10 on windows platform.

I have uncommented the line "extension=php_gd2.dll" and set the directory " extension_dir = "c:\php\extensions\" " where i have installed php in the php.ini file in c:windows. But it still doesn't work. Wondering where i had gone wrong.

Any advice will be greatly appreciated.

Rgds,
tristan

Check extension_dir and GD dll in it. Server restart is required. You should see GD module listed by echo phpinfo();

Check extension_dir and GD dll in it. Server restart is required. You should see GD module listed by echo phpinfo();

yes, i have checked the extension_dir and it has a php_gd2.dll in it, i have also restarted the server, but it still does not have the gd library. my info.php did not list the gd module.

rgds,
tristan

What can I say? All the time, it works easily for me. They say PHP version atleast 4.3; and you're using php4.3.10

Last small thing, I may suggest, please check if you're able to alter other settings in php.ini (check it vs phpinfo()).

The clue should be in php.ini. It is scarce possibility, if that dll is corrupted. My inspiration to encounter errors is always simple: Machine never errors! Hence, humans should correct their errors. Because we're only ones to error.

I use Apache, and it warns (while re/starting), if it misses any dll or module to load. IIS shows no warning.

Hope, you get with GD :cool:

What can I say? All the time, it works easily for me. They say PHP version atleast 4.3; and you're using php4.3.10

Last small thing, I may suggest, please check if you're able to alter other settings in php.ini (check it vs phpinfo()).

The clue should be in php.ini. It is scarce possibility, if that dll is corrupted. My inspiration to encounter errors is always simple: Machine never errors! Hence, humans should correct their errors. Because we're only ones to error.

I use Apache, and it warns (while re/starting), if it misses any dll or module to load. IIS shows no warning.

Hope, you get with GD :cool:

hi,

it seems like i can't alter other settings in php.ini

tried to change "enable_dl = On" in php.ini to "enable_dl=Off" , restart Apache, but phpinfo still shows that "enable_dl = On"

wat could be the problem that i could not alter php.ini settings?

any help or advice?

thanks,
tristan

Observe every possibility of error ..
Apache NOT warns; while restarting that it can't load GD dll ..!
Is it mean, your PHP is working by IIS?
phpinfo page shows Apache or IIS?
phpi.ini is I hope in Windows OS directory. Some dll perhaps php4ts.dll (I'm not remembering exactly) is required to be copied in Apache2 bin directory. I hope you'll soon catch the error ..

Hi,

I have successfully installed gd a few days ago, well i went thru thr process of re-installing apache, php and ,mysql again..but this time, i upgraded php to 4.3.4.

Anyway, thanks for your help all these while!

Rgds,
Tristan

This article has been dead for over six months. Start a new discussion instead.