0

I am having trouble debugging in sharepoint. It is acting like I am debugging a different dll than the one I made code for.

When stepping through it will skip lines occasionally and randomly just stop debugging. Often it will start debugging then stop randomly and show any new breakpoints I add as the hollow red circles to say it does not have symbols for it. Sometimes it never breaks at all.

I have deleted all the pdb files and all dlls to make sure I was getting new ones, but it did not change anything. I have tried restarting iis and visual studio and have done a rebuild. I restarted my virtual pc to no avail.

The only thing I can think that could be wrong is that it is cashing an old version of the dlls somewhere...

I am doing development in VS2008 on windows server 2003 sp2 with SharePoint 2007.

Any thoughts on the matter would be appreciated.

1
Contributor
1
Reply
2
Views
5 Years
Discussion Span
Last Post by divin757
0

My code was making a call to a web service that was not set to debugging mode. Seems how this was done asynchronously it could stop the debugging at any time. I still need to do more testing but I think this one is solved.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.