0

Not able to upload files on server. It is working fine in local.
I want to upload some files. In my previous server it was uploading without any error.. not in new server. I set folder permission to 777, still it is not uploading. I delete existing and create new folder, but still it is not uploading.

3
Contributors
2
Replies
3
Views
6 Years
Discussion Span
Last Post by veedeoo
0

With no code examples we cannot possibly begin to help you. Chances are though it is a global server issue. Do you maintain the server yourself or is it hosted?

0

Hi,

Copy codes and read instructions below.. For security reason, DO NOT post the url of your AnyNameYouWant.php

<?php phpinfo(); ?>

copy,paste on notepad, save as AnyNameYouWant.php, upload to your server, direct your browser to this file. e.g. YourDomainDotCom/AnyNameYouWant.php .

After performing the above recommendations, please post the following values of what you see on your YourDomainDotCom/AnyNameYouWant.php.

I need values for the following from your server configurations.

PHP Version anything below 5.2.7 is less problematic. Due to some issues not related to your questions, but will post my answer if addressed.

Server API CGI, FAST CGI or Apache module?

max_execution_time normally, a new hosting account gets about 30, and you need more than that. At least 1000 to 2000 is ideal.

post_max_size The value of this must be equal to the value of upload_max_filesize. In some server settings this value is preset to about 8M. Again 8M is not enough to accept file uploads for much bigger files.

upload_max_filesize The values here must be more than what you are trying to upload. Default server settings as handed to you by your hosting provider is set to 2M or 2MB. Depending on your server setting CGI or Apache module, we can do some adjustments to meet your needs.

Edited by veedeoo: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.