0

I am having the following issues setting up php probid on my virtual dedicated server.
I have virtual dedictaed server at godaddy.com. It has paralles plesk 10.4.4 and Cent OS 5. Iam having the following isses

  1. I cannot get the database to work correctly. I am getting access denied error instead of being redirected to theinstall page. Access denied for roo@localhost usingpassword no. This unsername and password are inccorect, i set up a new database for it, but I cannot grant privaleges in plesk 10 and I need it to have all
  2. I need access to the root to install zend optimizer and gd library
  3. I need aceess to the php.ini file to change the settings
3
Contributors
12
Replies
17
Views
5 Years
Discussion Span
Last Post by Tristan2036
0

first you need to ask godaddy hosting technical support if you have a root access credential on your vps server. These information should be on your account confirmation email. They normally require an additional identification like driver license. I am not sure if they still have the same policy when working on one of their client some two years ago. Did you have any other choice than plesk parallel (Never mind .. i just realized that your script is a business software, so plesk is the best choice)? Did you order the cpanel option with your vps account or does it already have a plesk panel included in the account?

The phpMyAdmin in plesk is different.. read more about it here

for your zend that is under the centos 5 .. You can install that using a terminal like putty found Here

Here is a good tutorial click here on how to install zend on centos.. just make sure you got the right flavor version .

Edited by veedeoo: more info added

0

I could have bought cpanel or another panel but got plesk. I'm reading on how to use putty. It's unclear to me on how to actually get the zipped file into the folder without the right ftp and permissions. I got all my scritps fields into the site using fielzeilla. But still the mysql connect error. I need to change the settings and permissions or else I can't set this up.

0

im no linux genius but i connect to mysql through putty using the command:

mysql -uuser -ppassword

no spaces after -u or -p

the user is usually root

Can you not get onto mysql through phpmyadmin on plesk?

0

Let's do this few steps at a time...

How to change file permission using FTP-> Filezilla

These can be done right on your desktop in the filezilla console.
1. Connect to your server using filezilla
2. Locate the folder or directory you want to change the permission.
3. Right click on the directory, and then select or click on the "File Permissions.."
4. On "Change file attributes" window prompt, change the "numeric value" to your software recommended permission.

Warning, some server API like CGI and FAST CGI recommends 755 which have the same equivalent as 777 if apache module is used as server API. If your software recommends 777 CHMOD, try the 755 first, and then if it does not work, go for the 777 CHMOD.

You can use the fileZilla to move your zip file from your desktop to your site. The reason I am recommending the use of putty is for the php.ini file update, zend optimizer installation, and the gd libary. These items cannot be done without terminal access or other people calls it SSH.

To unzip the zip files already in your server, you need to log on to your plesk panel and then extract the file. If you still not able to do it this way. Extract the files on your desktop, and then use fileZilla to upload all of the extracted files to your server..

0

I still can't find a way to get the tar file into the directory. I use the commands in the tutorial to download the file give me a 404 error.

0

try this..

log on to your remote site using putty.

  1. On the command box type

    wget http://downloads.zend.com/optimizer/3.3.9/ZendOptimizer-3.3.9-linux-glibc23-i386.tar.gz

Hit enter... you should be able to see donwload in progress including files being transferred from Zend for linux donwload.

Once the download is finished..decompress the tar, by typing the command below

tar zxf ZendOptimizer-3.3.9-linux-glibc23-i386.tar.gz

Hit enter again.... this should decompress your tar file. Look for confirmation like Done or any indication that it is done..

Once the decompression is finished, type the command below to moved the decompressed file to /usr/lib/php/modules/. Type command below..

cp ZendOptimizer-3.3.9-linux-glibc23-i386/data/5_1_x_comp/ZendOptimizer.so /usr/lib/php/modules/

Now we need to update our php.ini file for the zend optimizer's extension .so.. To do this we need the linux text editor (nano). Type the follwing comman on your terminal.

nano /etc/php.ini

Hit enter... the rest just follow if from the tutorial links I have provided above.. it should now work for you.. Once you are done witht he zend optimizer, do the gd

For the GD library.. first you need to check if there is an easy way to do this inside your plesk parallel.. Loof for a link like options in server management, and look for something that is related to apache update .. It's been a long time since the last time I am playing around with plesk, so my memory is pretty blury about the location of the option menu on plesk.

Edited by veedeoo

0

I guess your server don't have nano... lets try vi..

On your terminal again type.

cp /etc/php.ini /etc/php.ini_Default

The above command is for making a back up copy of your default php.ini file. Now, let's try if we can edit it with vi. Type this command

vi /etc/php.ini

There should be an editor like enterface on your black box (putty).. to insert, you must press "insert" on your keyboard and make sure you are seeing INSERT on your terminal. Start adding the zend option to this as instructed in the tutorial.

To save your changes press ESC on your keyboard..that should save your php.ini settings.. To make the changes takes effect on your server type

/etc/init.d/httpd restart

If everything goes well the zend optiomizer is now enabled. To confirm that the zend is enabled.. Copy, save, and upload through ftp to the root directory of your site..save this file as any name you want.

<?php

phpinfo();

?>

Direct your browser to this file... scroll down the page and look for the zend optimizer entries. If you prefer to confirm this through your putty command line, type

-v 

Hit enter... you teminal should show something about zend.. try the phpinfo() first... because you will be using it later for the gd library installation confirmation.

While you are running the phpinfo(), please confirm that your server's loaded configuration file is /etc/php.ini, if it is different than this, then you will have to do the above editing changing the location of the php.ini file as defined on your phpinfo().

Good luck...

Edited by veedeoo: more info added

0

Can you run the phpinfo() one more time?

What is the value of the "Loaded Configuration File"... I am expecting a value of etc/php.ini .

Copy this script and upload to your server, name it anyNameYouWant.php direct your browser to this file.

<?
 if(!function_exists('zend_optimizer_version')) echo "Zend Optimizer is not installed";
 else echo "Zend Optimizer info.: ".zend_optimizer_version();

 echo "<h2> Checking Zend Engine Version</h2>";
 echo "Zend engine version: " . zend_version();
?>

If the installation was successful, I am expecting the script above to give us something like "Zend Optimizer : ZendOptimizer-3.3.9" on the first line and on the second line should be " Checking Zend Engine Version Zend Engine version : 2.3.0 ". The 2.3.0 version might be different on your server.

NOrmally, phpinfo(), will print out a page.. the very first table shows your php version, the second table is your system summary, and then there will be Zend information table with Zend logo on it.. and an announcement like "This program makes use of the Zend Scripting Language Engine: Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies"

If you don't have those, then your VPS don't have the Zend Engine on it that's for sure.. You can try asking the GoDaddy support department if they can add this on your package. I must refrain from giving any comments about godaddy hosting department. I love their domain registration, but I cannot comment on the hosting side.

0

I found some unstructions saying the 3.3.9 version does not have an installer file and to un tar then ftp the .so file. Imay try this if I can find out how to use putty ftp. It will also be easier to edit the php.ibni file that way. It is 2.3.0 and no Zend Optimizer. When I upload it seems to work and I get a confirmation. It just will not untar. eEither no confirmation or no such directory error. Is there a command line to just uypload th untarred fversion straight from computers documents folder to the php directory on the server?

0

Okay, I think should post an update. I have been trying to install zend. And I realized that this sevrer is uising php 5.3.3. Tried to change it down to 5 in plesk. This did not work so I asked goadaddy what could be done and they said. I also finally got the ftp working and found zend already installed. So it seems that I'll need to pay them. I tried downloading the ioncube version of phpprobid and it all went well except that there are these cpatcha images that wont show. I don't know where in the script they are stored. Without them showing unfotunately I cannot login to admin nor can anyone register. But I'll go ahead and mark the zend thread as solved.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.