hello,
I have a problem with database. there is a syntax error unexpected T_variable. could you please tell me what is the error in this script? thank you

Hy,
It is missing " / " before " * " on first line, that begins the comments.
Also, delete " /** " from the end.

The /** on the end is probbably the missing one from the beginning. Just move it from the last row to the first row and insert a newline immediately after it. /** is a beginning of a comment that can be used for documentation purposes. See http://www.phpdoc.de/ or http://phpdoc.org/

Click Here I copied that part of a script where the error is. Here is the whole script. error is in 63 line. Sorry for disturbing you again

The above link is not working. Can you post the code here?

<?php
/**
 * The base configurations of the WordPress.
 *
 * This file has the following configurations: MySQL settings, Table Prefix,
 * Secret Keys, WordPress Language, and ABSPATH. You can find more information
 * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
 * wp-config.php} Codex page. You can get the MySQL settings from your web host.
 *
 * This file is used by the wp-config.php creation script during the
 * installation. You don't have to use the web site, you can just copy this file
 * to "wp-config.php" and fill in the values.
 *
 * @package WordPress
 */

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define('DB_NAME', 'XXXXXXXXXX');

/** MySQL database username */
define('DB_USER', 'XXXXXXXXXX');

/** MySQL database password */
define('XXXXXXXXXX', '');

/** MySQL hostname */
define('DB_HOST', 'XXXXXXXXXXX');

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');

/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

/**#@+
 * Authentication Unique Keys and Salts.
 *
 * Change these to different unique phrases!
 * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
 * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
 *
 * @since 2.6.0
 */
define('AUTH_KEY',         'put your unique phrase here');
define('SECURE_AUTH_KEY',  'put your unique phrase here');
define('LOGGED_IN_KEY',    'put your unique phrase here');
define('NONCE_KEY',        'put your unique phrase here');
define('AUTH_SALT',        'put your unique phrase here');
define('SECURE_AUTH_SALT', 'put your unique phrase here');
define('LOGGED_IN_SALT',   'put your unique phrase here');
define('NONCE_SALT',       'put your unique phrase here');

/**#@-*/

/**
 * WordPress Database Table prefix.
 *
 * You can have multiple installations in one database if you give each a unique
 * prefix. Only numbers, letters, and underscores please!
 */
$table_prefix  = 'wp_';

/**
 * WordPress Localized Language, defaults to English.
 *
 * Change this to localize WordPress. A corresponding MO file for the chosen
 * language must be installed to wp-content/languages. For example, install
 * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
 * language support.
 */
define('WPLANG', '');

/**
 * For developers: WordPress debugging mode.
 *
 * Change this to true to enable the display of notices during development.
 * It is strongly recommended that plugin and theme developers use WP_DEBUG
 * in their development environments.
 */
define('WP_DEBUG', false);

/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

what is error line number?
Also for testing remove all comments once and then try.

The code you posted has no syntax errors. It contains definitions of constants and each definition is preceded with explanation within comment marks (mostly phpdoc /** */comment marks are used). Are you getting the same error as described above? Can you copy the whole error message and post it here?

A few days ago it showed that there was parse error: syntax error unexpected T_variable - line 63. Now it shows error establishing a database connection

That is a completely different thing. This could be due to wrong credentials that are defined as constants in the above script in lines 19 to 34. Have you set them correctly?

I fixed it. I had put the password in a wrong place. I had replaced DB_PASSWORD with my password. Thank you for your attention, you helped me a lot :)