0
Hi,

PHP 5.2.17 (cli) (built: Sep  1 2011 17:22:41)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

[root@ip-10-130-243-182 mnt]# yum install php-pecl-memcached-2.1.0-1.el6.remi.x86_64.rpm
Loaded plugins: fastestmirror
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository addons is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration
Loading mirror speeds from cached hostfile
 * base: mirror.usonyx.net
 * epel: mirror.nus.edu.sg
 * extras: mirror.usonyx.net
 * updates: mirror.usonyx.net
Setting up Install Process
Examining php-pecl-memcached-2.1.0-1.el6.remi.x86_64.rpm: php-pecl-memcached-2.1.0-1.el6.remi.x86_64
Marking php-pecl-memcached-2.1.0-1.el6.remi.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-memcached.x86_64 0:2.1.0-1.el6.remi set to be updated
--> Processing Dependency: php(zend-abi) = 20090626-x86-64 for package: php-pecl-memcached
--> Processing Dependency: php(api) = 20090626-x86-64 for package: php-pecl-memcached
--> Processing Dependency: php-common(x86-64) >= 5.2.10 for package: php-pecl-memcached
--> Processing Dependency: php-pecl-igbinary(x86-64) for package: php-pecl-memcached
--> Processing Dependency: libmemcached.so.10()(64bit) for package: php-pecl-memcached
--> Running transaction check
---> Package php-pecl-memcached.x86_64 0:2.1.0-1.el6.remi set to be updated
--> Processing Dependency: php-common(x86-64) >= 5.2.10 for package: php-pecl-memcached
--> Processing Dependency: php-pecl-igbinary(x86-64) for package: php-pecl-memcached
--> Processing Dependency: libmemcached.so.10()(64bit) for package: php-pecl-memcached
---> Package php53-common.x86_64 0:5.3.3-13.el5_8 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
**php-pecl-memcached-2.1.0-1.el6.remi.x86_64 from /php-pecl-memcached-2.1.0-1.el6.remi.x86_64 has depsolving problems
  --> Missing Dependency: php-pecl-igbinary(x86-64) is needed by package php-pecl-memcached-2.1.0-1.el6.remi.x86_64 (/php-pecl-memcached-2.1.0-1.el6.remi.x86_64)
php-pecl-memcached-2.1.0-1.el6.remi.x86_64 from /php-pecl-memcached-2.1.0-1.el6.remi.x86_64 has depsolving problems
  --> Missing Dependency: libmemcached.so.10()(64bit) is needed by package php-pecl-memcached-2.1.0-1.el6.remi.x86_64 (/php-pecl-memcached-2.1.0-1.el6.remi.x86_64)
php53-common-5.3.3-13.el5_8.x86_64 from updates has depsolving problems
  --> php53-common conflicts with php-common
php-pecl-memcached-2.1.0-1.el6.remi.x86_64 from /php-pecl-memcached-2.1.0-1.el6.remi.x86_64 has depsolving problems
  --> Missing Dependency: php-common(x86-64) >= 5.2.10 is needed by package php-pecl-memcached-2.1.0-1.el6.remi.x86_64 (/php-pecl-memcached-2.1.0-1.el6.remi.x86_64)**
**Error: Missing Dependency: php-pecl-igbinary(x86-64) is needed by package php-pecl-memcached-2.1.0-1.el6.remi.x86_64 (/php-pecl-memcached-2.1.0-1.el6.remi.x86_64)**
Error: Missing Dependency: libmemcached.so.10()(64bit) is needed by package php-pecl-memcached-2.1.0-1.el6.remi.x86_64 (/php-pecl-memcached-2.1.0-1.el6.remi.x86_64)
**Error: php53-common conflicts with php-common
Error: Missing Dependency: php-common(x86-64) >= 5.2.10 is needed by package php-pecl-memcached-2.1.**0-1.el6.remi.x86_64 (/php-pecl-memcached-2.1.0-1.el6.remi.x86_64)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@ip-10-130-243-182 mnt]#


please help 
2
Contributors
1
Reply
2
Views
5 Years
Discussion Span
Last Post by maba001
0

Hello chandbasha,

this is probably the wrong place to post a basic Linux package management question.

The PECL package you are trying to install fails on the yum / rpm dependency checks. So my first wild guess is that you are using some sort of Fedora. To solve this, you should check whether there is a memcache package for PHP 5.3 on one of the repository servers. If not, you have two options:
1) downgrade PHP to version 5.2 (this would mean a remove of the current php53-... packages and a then an install of the standard php-.. stuff)
2) compile from source

Good luck
Maba

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.