0

help please!!!

i have installed xampp v3.1.0.3.1.0

it seems that my apache is not really working

everytime i click once apache it turns yellow then says

9:39:44 PM  [Apache]    Status change detected: stopped
9:39:44 PM  [Apache]    Error: Apache shutdown unexpectedly.
9:39:44 PM  [Apache]    This may be due to a blocked port, missing dependencies, 
9:39:44 PM  [Apache]    improper privileges, a crash, or a shutdown by another method.
9:39:44 PM  [Apache]    Check the "/xampp/apache/logs/error.log" file
9:39:44 PM  [Apache]    and the Windows Event Viewer for more clues

help please what to do?

6
Contributors
6
Replies
9
Views
4 Years
Discussion Span
Last Post by veedeoo
0

That because something is using port 80. in the control panel, there is a button called port check. It will tell you what program is using that port.

0

always happened to me, the best way is:

  1. Uninstall xampp
  2. Re-install xampp

but make sure back-up all the files

0

Try uninstalling Xampp and installing Wamp server. I had the same issue, and I couldn't get xampp to work at all. So I installed Wamp, and it still wasn't working. I had to go into the httpd.config file and change the listen port from 80 to 8080. Then when you want to go to your sever you have to type either 127.0.0.1:8080 or localhost:8080. Hope that helped some!

0

It is all about port 80, the windows just won't allow it. Check your firewall settings or whatever windows security they have. If you have a flash drive handy, and if interested in discovering other server apps, try portable nginx.. this is one fast server, but there is a limitation though nginx does not support .htaccess. I could help re-writing a minor .htaccess to nginx equivalent mod-rewrite. As long as it is not one full page..

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.