0

while giving command

zf create action login

i get the error

PHPUnit is required in order to generate controller test stubs.

-------------any suggestions

4
Contributors
10
Replies
26
Views
4 Years
Discussion Span
Last Post by kakalahori
Featured Replies
  • Try this Reference : [Click Here](http://www.zend-framework-community.634137.n4.nabble.com/Question-about-underscores-in-controller-and-action-names-td656525.html) Read More

  • 1

    @kakalahori You need to install the PHPUnit module. This can be easily done via PEAR http://pear.php.net/manual/en/installation.getting.php Or via GIT https://github.com/sebastianbergmann/phpunit/ I used PEAR in my set up as it also allows access to the pre compiled libraries. Read More

  • >i have php5.3.13 and PhpUnit 3.8 requires php5.4 above .....any other link ?? May I ask why are you going backward with certain requirements? I hope understand it's hard to find packages that far back. But even you used the package there are certain PHP function might not work. Read … Read More

  • 1

    @LastMitch, Thats the link i couldnt find :) +1 Read More

0

PHPUnit is required in order to generate controller test stubs.

The reason why that message appear because you don't have PHPUnit installed yet.

Installed PHPUnit and that message won't appear again.

OK, did you installed ZF2 yet (correctly) from the preivous thread that you post?

Edited by LastMitch: grammer

0

last mich im using ZF1 and its all configured and runing and showing this error

0

@kakalahori

last mich im using ZF1 and its all configured and runing and showing this error

OK, so you are using ZF1 now.

Squidge provided couple of links on how to installed PHPUnit module.

Try it and lets us know what issue you are still having with the PHPUnit module.

0

ihave php5.3.13 and PhpUnit 3.8 requires php5.4 above .....any other link ??

2

i have php5.3.13 and PhpUnit 3.8 requires php5.4 above .....any other link ??

May I ask why are you going backward with certain requirements?

I hope understand it's hard to find packages that far back. But even you used the package there are certain PHP function might not work.

Read this and scroll down to (PHPUnit - The PHP Unit Testing framework):

http://pear.phpunit.de/

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.