0

When I open the security page in my xamp (from my local host) I get this message:

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\security\htdocs\security.php on line 100

Why is it that I receive this message?

3
Contributors
16
Replies
20
Views
4 Years
Discussion Span
Last Post by LastMitch
Featured Replies
  • It is taking longer than 30 seconds to execute. You can increase the max execution time in the php.ini file. max_execution_time Read More

  • Sorry, updated the post after you saw it. max_execution_time = 30 I am pretty sure the default login is User: root Pass: root Read More

  • >I am just trying to figure out what the log in is for my phpmyadmin... There is no log-in because you just click the tab and it open the **phpmyadmin** Maybe I miss something I had this install about a year ago. Read More

  • It is supposed to be installed by default already. Read More

  • username: root@localhost password: none(emtpy) Read More

1

It is taking longer than 30 seconds to execute. You can increase the max execution time in the php.ini file.

max_execution_time

Edited by pixelsoul

0

Okay so, I found the php.ini file but where do i make the changes and how do i put it back on xampp...

I am just trying to figure out what the log in is for my phpmyadmin...

2

Sorry, updated the post after you saw it.

max_execution_time = 30

I am pretty sure the default login is
User: root
Pass: root

Edited by pixelsoul

1

I am just trying to figure out what the log in is for my phpmyadmin...

There is no log-in because you just click the tab and it open the phpmyadmin

Maybe I miss something I had this install about a year ago.

0

how do I save it if I change the max_execution_time to 60?

And why is it that when I open up the file it doesn't look like code? it looks more like a bunch of commenting done in a way I have not seen it before...

0

on my xampp, there is a link to phpmyadmin, does that mean I have to download it or does that mean it is already installed when I installed xampp?

0

Also where is max_execution_time when I open up the file....?

Sorry mods for my excessive posting...

1
username: root@localhost
password: none(emtpy)
0

There is no log-in because you just click the tab and it open the phpmyadmin
Maybe I miss something I had this install about a year ago.

There is a log in on mine.

0

username: root@localhost
password: none(emtpy)

okay, where is that in my php.ini file?

0

I have to point this out, this is like the fastest pace assistance in the history of daniweb :) we are posting every like 20 seconds... sorry I had to point that out.

1

On your php.ini file:

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 60

Edited by LastMitch: grammer

1

The php.ini file doesn't have "code", it is just an ini file with configuration settings.
If you open it up in notepad you should be able to find a line in the file that has max_execution_time.

Just change the value for this and hit save, that's all.

0

Okay, I am searching the php.ini file and there is almost 2100 lines of code... where would it be in the "code"?

1

Okay, I am searching the php.ini file and there is almost 2100 lines of code... where would it be in the "code"?

line 451

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.