When I open the security page in my xamp (from my local host) I get this message:

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\security\htdocs\security.php on line 100

Why is it that I receive this message?

Recommended Answers

It is taking longer than 30 seconds to execute. You can increase the max execution time in the php.ini file.

max_execution_time

Jump to Post

Sorry, updated the post after you saw it.

max_execution_time = 30

I am pretty sure the default login is
User: root
Pass: root

Jump to Post

I am just trying to figure out what the log in is for my phpmyadmin...

There is no log-in because you just click the tab and it open the phpmyadmin

Maybe I miss something I had this install about a year ago.

Jump to Post

It is supposed to be installed by default already.

Jump to Post

All 16 Replies

It is taking longer than 30 seconds to execute. You can increase the max execution time in the php.ini file.

max_execution_time

Okay so, I found the php.ini file but where do i make the changes and how do i put it back on xampp...

I am just trying to figure out what the log in is for my phpmyadmin...

Sorry, updated the post after you saw it.

max_execution_time = 30

I am pretty sure the default login is
User: root
Pass: root

Member Avatar

I am just trying to figure out what the log in is for my phpmyadmin...

There is no log-in because you just click the tab and it open the phpmyadmin

Maybe I miss something I had this install about a year ago.

how do I save it if I change the max_execution_time to 60?

And why is it that when I open up the file it doesn't look like code? it looks more like a bunch of commenting done in a way I have not seen it before...

on my xampp, there is a link to phpmyadmin, does that mean I have to download it or does that mean it is already installed when I installed xampp?

It is supposed to be installed by default already.

Also where is max_execution_time when I open up the file....?

Sorry mods for my excessive posting...

Member Avatar
username: root@localhost
password: none(emtpy)

There is no log-in because you just click the tab and it open the phpmyadmin
Maybe I miss something I had this install about a year ago.

There is a log in on mine.

username: root@localhost
password: none(emtpy)

okay, where is that in my php.ini file?

I have to point this out, this is like the fastest pace assistance in the history of daniweb :) we are posting every like 20 seconds... sorry I had to point that out.

Member Avatar

On your php.ini file:

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 60

The php.ini file doesn't have "code", it is just an ini file with configuration settings.
If you open it up in notepad you should be able to find a line in the file that has max_execution_time.

Just change the value for this and hit save, that's all.

Okay, I am searching the php.ini file and there is almost 2100 lines of code... where would it be in the "code"?

Member Avatar

Okay, I am searching the php.ini file and there is almost 2100 lines of code... where would it be in the "code"?

line 451

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.