0

I am using phpmyadmin on my computer and while I tried to update my data, the following happens " Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0 ".

I tried to search " php.ini " on my computer, but I can't find it anywhere. Does this mean I have to create one by myself? If so, where should I put the file?

I am not exactly sure what to do.

Thank you very much.

3
Contributors
11
Replies
44
Views
4 Years
Discussion Span
Last Post by jeffadrian
Featured Replies
  • 1

    Hi, copy, paste to notepad, save as whateverfile.php, and direct your browser to this file. <?php phpinfo(); ?> Look for the value of this Loaded Configuration File Using your windows explorer and locate the php.ini file as shown on your Loaded Configuration File . Change the values of the following … Read More

  • 1

    I forgot to tell you that you will need to restart the apache server. Read More

  • 1

    To answer your last question, you can either increase it to or higher. It is your call. Don't forget to restart the apache. max_input_vars = 3000 Read More

  • 2

    To help you out more, this is how the default setting would look like ;;;;;;;;;;;;;;;;;;; ; Resource Limits ; ;;;;;;;;;;;;;;;;;;; ; Maximum execution time of each script, in seconds ; http://php.net/max-execution-time ; Note: This directive is hardcoded to 0 for the CLI SAPI max_execution_time = 30 ; Maximum amount of … Read More

  • 1

    Dude, It can't be the same result if you are following my first response, Where it says look for the value of the "**Loaded Configuration File**".. The value assigned to the loaded configuration file is the location of the php.ini file currently being loaded by the apache server to initialize … Read More

1

Hi,

copy, paste to notepad, save as whateverfile.php, and direct your browser to this file.

<?php 

    phpinfo(); 

    ?>

Look for the value of this

Loaded Configuration File 

Using your windows explorer and locate the php.ini file as shown on your Loaded Configuration File .

Change the values of the following

post_max_size
upload_max_filesize

it is ok to give it a higher value like 200M.

last thing, change this value to a higher value as needed by your php applications..

max_execution_time
0

I am able to find this " php.ini " file on my computer

Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

I did change the value of max_input_vars, but it's still not working. What's the value that I should change to?

Edited by jeffadrian

1

To answer your last question, you can either increase it to or higher. It is your call. Don't forget to restart the apache.

max_input_vars = 3000
2

To help you out more, this is how the default setting would look like

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 30

; Maximum amount of time each script may spend parsing request data. It's a good
; idea to limit this time on productions servers in order to eliminate unexpectedly
; long running scripts.
; Note: This directive is hardcoded to -1 for the CLI SAPI
; Default Value: -1 (Unlimited)
; Development Value: 60 (60 seconds)
; Production Value: 60 (60 seconds)
; http://php.net/max-input-time
max_input_time = 60

; Maximum input variable nesting level
; http://php.net/max-input-nesting-level
;max_input_nesting_level = 64

; How many GET/POST/COOKIE input variables may be accepted
; max_input_vars = 1000

; Maximum amount of memory a script may consume (128MB)
; http://php.net/memory-limit
memory_limit = 128M

change this

 ; max_input_vars = 1000

to this

 max_input_vars = 3000

comment line in php.ini file is

;

If you have suhosin installed, consult their docs.

0

I did the restart and also reboot my computer, but unfortunately the result is still the same.

1

Dude,

It can't be the same result if you are following my first response, Where it says look for the value of the "Loaded Configuration File"..

The value assigned to the loaded configuration file is the location of the php.ini file currently being loaded by the apache server to initialize the PHP support.. that's simple..

DO NOT EDIT the php.ini file located in the C:\WINDOWSthis is a system php.ini file. Apache needs to at least tell the mother ship what it intends to do..

This-> Loaded Configuration File and NOT this ->** Configuration File (php.ini) Path**

Normally, the loaded configuration file is located in the php directory compiled with the apache2..for example

C:\php\php.ini 

If you are using wamp or xampp, it is more likey located in

C:\xampp\php\php.ini 

Edited by veedeoo: info added

0

I used xampp, so I did change the value in the xampp folder which is " C:\xampp\php\php.ini ". I didn't change any other place. I restarted apache from the xampp control panel and also restart my computer, but nothing happened I still see this error " Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0 "

0

After multiple times of rebooting, there's no more error. Thank you very much for all your help.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.