0

This is going to sound really stupid, but I'm using 'plesk' and I've written the very simplest form of php mail function. However, it doesn't arrive in my email account. I've tried different email accounts and looked in my spam bin. I've waited days to be sure.

I've checked everywhere in 'plesk' but I just can't see what I'm missing. Oddly, wordpress's mail function seems to be working. I'm not sure if this uses php mail's function.

Any help or clues would be greatly appreciated.

2
Contributors
6
Replies
41
Views
3 Years
Discussion Span
Last Post by iamthwee
0

Paste your code here and let the community look whats wrong with that.
keep that in mind that "you cannot send emails from you local server unless and untill you have configured mercury"

0

The mail script is fine. It's the bare bone essentials, additionally the same script works on another server.

I am not on a local server this is a plesk panel on a dedicated server in the cloud.

The issue is my mail doesn't get sent. At the moment I'm using gmail's SMPT to circumvent this, but I'd much rather use the mail() function.

I can post a screenshot of my mail settings under plesk?

0

I still looking for an answer my php ini file has the values:

[mail function]
mail.add_x_header = On
sendmail_path = /usr/sbin/sendmail -t -i
smtp_port = 25
smtp = localhost

0

Guys a got a little closer to finding the solution:

http://forum.parallels.com/showthread.php?62570-php-mail()-function-not-working

Using the email form listed in the above thread I was able to receive an email to my hotmail address. But when I tried sending an email to my gmail account it didn't come through. Could it be that the domain on my gmail account is the same as the server I'm trying to send it from?

1

But we still need to look into your code. May be there are some server settings isseu or some thing else

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.