0

OK, so I've been Googling this as well as looking for previous posts. I have a .NET site that has some classic ASP still in it (who knows why or who did that). On the old server, the ASP would execute normally. On the new server, however, the ASP code renders to the browser. Both servers so far seem setup identically, and are running Windows 2008 R2. I've checked that ASP is installed, the app pools are the same, permissions the same, etc. I have to be missing something, but am not seeing the "smoking gun", as it were. Any ideas?

3
Contributors
12
Replies
45
Views
3 Years
Discussion Span
Last Post by CaffeineCoder
0

I've checked that ASP is installed

Are you absolutely sure that ASP is enabled? Go to:

Server Manager
---Web Server (IIS)
------Add Role Services

Select these role services..

-ASP
-Request Filtering
-ISAPI Extensions

0

Something else that may have happened to that page? If you create a new page and simply add...and nothing else.

<% Response.Write ("Hello World!") %>

This would work if Classic ASP is enabled and regardless if your page is .asp or .aspx.

0

Thanks. I tried your suggestion, but it just opened the code in the browser instead of executing.

0

How can I tell? I would say no, but not going to rule out anything. Starting to wonder if I need to remove the Applications role and re-add it.

0

I'm leaning towards uninstalling the Role, and then reinstalling it. Maybe that would fix?

0

I'd try that. Adding/Removing roles should cause you more problems. In addition, you already have an old server that you can look at with regard to the configuration so it seems reasonable especially for Windows systems. Sometimes these quirky issues are resolved with simple reboots or uninstalling/reintsalling the component. keep us informed.

0

Thanks JorgeM. Had to re-read your first part above. Before posting here, I had googled as well as compared the old server with the new. Finally posted here as a last-ditch "OK, what am I missing" sort of thing. Will let you guys know how it goes.

0

So apparently, the CMS platform Ektron was overriding settings in the OS. The Configs had to be altered to get the stupid thing to work. Go figure.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.