1

hello everyone! im using ozeki sms gateway for my website. but for some reason (which i dont know) when i use and implement the script i have on my uploaded website it doesnt work. i get an error message as follows:

Request:
http://192.168.254.103:9501/api?username=php1&password=12151989&action=sendmessage&messagetype=SMS:TEXT&recipient=%2B639355537225&messagedata=dddd

Warning: fsockopen(): unable to connect to 192.168.254.103:9501 (Connection timed out) in /home/lyceumli/public_html/sendsms.php on line 18
Response:
Connection timed out (110)

192.168.254.103:9501 --> thats my local ip address or the ipv4 address of my computer with 9501 as the port of ozeki sms gateway, in my localhost, it works fine. Ive sought tutorials and reviews and even tips from ozeki themselves, they advised me to turn off my firewall, port forward 9501 to my router, and such likes but the error remains. Any idea on how will I solve this problem? if you wish to check it out, go to lyceumlibrary.com; i have there the sms form.

Thanks a lot!

4
Contributors
4
Replies
28
Views
3 Years
Discussion Span
Last Post by Tom87
1

If you are trying to connect to 192.168.254.103:9501 from a host on the Internet, that isn't going to work. This is a private IP address. It's not public ally routable on the Internet.

If you are trying to connect to a host in your private network, you have to specify your public IP address and set up your router to map this public IP to the internal private IP on the appropriate ports.

For this to work, your public IP must be static. Your ISP controls whether its static or dynamic.

0

thanks for the reply JorgeM,

any tutorials on setting up my router map of public IP to my private IP assuming my public IP is static? or is there an alternative way to have my sms over the net? or any tutorials i can read to implement my sms from my website in the internet? im a newbie on this so I am relying on tutorials and google on how i can make this work.

thanks a lot!

0

Hey!

For using the sms gateway you will need a static IP adress. Ask for your service provider about it.

Here's a guide about how you can enable the Ozeki NG SMS Gateway in a private network: <URL SNPPED>

You do not need to turn off the firewall, just allow the requests through port 9501 to connect to Ozeki.
Try to search solution in the routers manual about this port forwarding.

Edited by peter_budo: URL snipped

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.