I've recently received some ASP.NET application to test. I must run it on local server. I installed IIS with all components. I copied whole project to c:\inetpub\wwwroot. Catalog structure:

4eeea10396f106716ea9eee3fcc78a78

I suppose main file to run is Global.asax, but when i try to run localhost/.../global.asax I get error:

HTTP Error 404.3 - Not Found Description: The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and is not allowed.

ASP.NET is completely new technology for me. I guess there is very easy solution ;)

Recommended Answers

Copying the source to the web root is not really useful. You should put your project somewhere else, and then use the Publish option in Visual Studio to build a version for deployment on IIS.

Jump to Post

All 2 Replies

Copying the source to the web root is not really useful. You should put your project somewhere else, and then use the Publish option in Visual Studio to build a version for deployment on IIS.

Global.aspx is not intended for you to access via a web browser. There are certain files that the asp.net engine will not allow you to access via a browser. For example, *.config files cannot be either.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.21 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.