Hello friends....

I have configure my apache soap.....
It is saying that after configuration if i go on "http://localhost:8080/soap/servlet/rpcrouter"
it will give following message......
"Sorry, I don't speak via HTTP GET- you have to use HTTP POST to talk to me."

But in my case it is throwing exception which is pasted below...

I am using tomcat apache server... soap 2.3.1

My class path is:
set classpath=C:\Jars\bsf.jar;C:\Jars\js.jar;C:\Jars\activation.jar;C:\Jars\xerces.jar;C:\Jars\activation.jar;C:\Jars\soap-bin-2.3.1\soap-2_3_1\lib\soap.jar;C:\Jars\soap-bin-2.3.1\soap-2_3_1;C:\Jars\javamail-1_4\javamail-1.4\mail.jar;C:\ch3;C:\Program Files\Java\jdk1.5.0_04\lib\tools.jar;C:\Program Files\Java\jdk1.5.0_04\jre\lib\javaws.jar;C:\Program Files\Java\jdk1.5.0_04\jre\lib\rt.jar;

and Exception is:

======================================================
type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Servlet.init() for servlet rpcrouter threw exception
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:535)
org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:790)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:709)
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:572)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:644)
java.lang.Thread.run(Thread.java:595)


root cause

java.lang.NoClassDefFoundError: javax/mail/MessagingException
org.apache.soap.server.http.RPCRouterServlet.init(RPCRouterServlet.java:239)
javax.servlet.GenericServlet.init(GenericServlet.java:256)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:535)
org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:790)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:709)
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:572)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:644)
java.lang.Thread.run(Thread.java:595)


note The full stack trace of the root cause is available in the Tomcat logs.

==================================================

Please help me as soon as possible... Pleaaaaaaaase
:cry: aLwAys vAgHu :cry:

:idea:

Hello friends....

I hope u must hav got your ans by now in case u haven't then I can let you know the fix for this.

1) Apache SOAP is deprecated. Use Axis instead.
2) What's not clear about that message? It's pretty obvious that you're using the wrong request protocol.

This article has been dead for over six months. Start a new discussion instead.