0

I cant find solution for this problem so i hope someone of u can help
When i set seo settings** Use URL rewriting = yes** in Joomla than my site crashes
It must be Use URL rewriting=yes
How to make my joomla site user friendly with this problem?

this is in my htaccess file
Begin - Joomla! core SEF Section.

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

If the requested path and file is not /index.php and the request
has not already been internally rewritten to the index.php script

RewriteCond %{REQUEST_URI} !^/index\.php

and the request is for something within the component folder,
or for the site root, or for an extensionless URL, or the
requested URL ends with one of the listed extensions

RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]

and the requested path and file doesn't directly match a physical file

RewriteCond %{REQUEST_FILENAME} !-f

and the requested path and file doesn't directly match a physical folder

RewriteCond %{REQUEST_FILENAME} !-d

internally rewrite the request to the index.php script

RewriteRule .* index.php [L]

Edited by pritaeas: Fixed markdown.

2
Contributors
13
Replies
41
Views
3 Years
Discussion Span
Last Post by LONGWAY
0

Joomla have provided some possible server related problems here.

An alternative way of doing this is by renaming the htaccess.txt to .htaccess included in the distribution as mentioned here.

in the htaccess.txt, there is also an instruction there about Options +FollowSymLinks must be commented out if causes errors.

0

[Mon Aug 11 15:18:22.2014] [ssl:warn] [pid 9000:tid 200] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Aug 11 15:18:22.381667 2014] [core:warn] [pid 9000:tid 200] AH00098: pid file D:/Instalacija/XAMPP/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Aug 11 15:18:22.2014] [ssl:warn] [pid 9000:tid 200] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Aug 11 15:18:22.2014] [mpm_winnt:notice] [pid 9000:tid 200] AH00455: Apache/2.4.7 (Win32) OpenSSL/1.0.1e PHP/5.5.6 configured -- resuming normal operations
[Mon Aug 11 15:18:22.2014] [mpm_winnt:notice] [pid 9000:tid 200] AH00456: Apache Lounge VC11 Server built: Nov 21 2013 20:13:01
[Mon Aug 11 15:18:22.2014] [core:notice] [pid 9000:tid 200] AH00094: Command line: 'd:\xampp\apache\bin\httpd.exe -d D:/XAMPP/apache'
[Mon Aug 11 15:18:22.2014] [mpm_winnt:notice] [pid 9000:tid 200] AH00418: Parent: Created child process 10032
[Mon Aug 11 15:18:23.2014] [ssl:warn] [pid 19000:tid 200] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Aug 11 15:18:24.2014] [ssl:warn] [pid 19000:tid 200] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Aug 11 15:18:24.2014] [mpm_winnt:notice] [pid 19000:tid 200] AH00354: Child: Starting 150 worker threads.

i get something like this...not sure if it helps

0

I tried installing Joomla on my development stack (uniform server, but for some reason I cannot replicate your problem.

I am assuming this maybe an xampp related problem. The server error log don't give me enough info. as to why joomla is crashing.

0

well tnx anyway

this i did

I run the site in win7 with xampp and i want to be user friendly.
I changed htaccess.txt to .htaccess
when i start it udner localhost the first page is opened succesfully without showing index.php but when I load any other tab/menu I get (localhost/joomla/alies.html) and error 404. than after localhost/joomla I manually write idnex.php in front of alies.html and the page is visible without err 404

is removed from the LoadModule rewrite_module modules/mod_rewrite.so

0

okay, now I know what is going on. Some version of Xampp is not so friendly with windows7. I am not sure which version were they, but what I was hearing from friends that it has something to do with the compiler used by xampp. Most WAMP stacks are compiled in MSVC9 (Visual C++ 2008) and then someone experimented compiling them on MSVC10 not knowing the implications in Win7 environment.

The only advice I can give you is to maybe consider an alternative to XAMPP. There is a production ready minified server called uniform server. This particular stack can run as indepent application.

If you ever decided to test the uniform server, make sure to make a back-up copy of your database in xampp. Remember, they cannot run at the same time by default.

0

the zeroxi is their latest release. Some people use this to host their site from a thumb drive and it is pretty stable. The phpmyAdmin is also secure on this one compared to xampp.

Edited by veedeoo: more info added

0

and u mean i cant have instaled xampp and uniserver at same time

0

you can have them installed at the same, but they cannot run at the same time using the same port.

0

i get this
Error displaying the error page: Application Instantiation Error

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.