0

I am trying to install Zend via a composer command in Linux. I am following the official Zend tutorial. And I am able to make a simple application, which is working perfectly. However, when I follow this tutorial's advice to use composer development-enabl e. But an CommandNotFound Exception is appearing if I am using composer dev...-enable and executing the full command:-

Command "development-enable" is not defined.

I am looking forward to someone, who has successfully able to fix this issue?

I am thinking, this is a common issue with $PATH value. At the same time, I am implementing composer command without any issues. Then, there are more chances of some issues with subcommand. Something likes missing important dependency.
The tutorial, I am following is this one: docs.zendframeworkdotcom/tutorials/getting-started/skeleton-application/
I am using Command Line Interface, with version 5.4.43. Also, I can't update this version. As I have Apache server 5.6 on my machine and also, I am using bash shell.

Failed solutions tried in the past:

Solution 1
On trying to rerun my installation with composer create-project (as you can see in the above tutorial) is not improving the solution.
Solution 2
I have already tried 'composer "development-enable"' without any success. I have implemented composer.json with development enabled and also I am running the composer in CLI on the root.
Solution 3
Someone suggested about issues in installation, so I have reinstalled the framework. After reinstalling, this thing keeps on appearing.
Also, I am having another issue, which is disturbing the design of my whole website. I am trying to use an API in jquery and implement maps on top and middle of the article (This map is the zoomed in version of the map at the top). I am able to successfully load the map at the top. But, on trying to load map at middle of the article, I am getting roman subscript and with loading is slowed. Example: my clients’ website contains directories like http://militarybases.co/directory/dugway-proving-ground-army-base-in-tooele-county-ut/. I will be showing the Dugway proving ground army base maximized version? In the above example, I have removed the map from the middle. But it is coming with issues. So there are 2 issues, 1-random roman script and 2-slow loading.

Can, anyone suggest any solution for this too?

3
Contributors
2
Replies
11
Views
1 Year
Discussion Span
Last Post by Daniel_69
2

Was stuck on the same problem as well for a day and found that upgrading from php 5.5.9 to 5.6 fixed the issue. Thanks :)

Edited by Daniel_69: PHP version wrong

Votes + Comments
you're welcome!
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.