0

Hello,

I am trying to install laravel for the first but unable to do so. I already install the composer and it has error since it request php7.dll is missing from my computer. Where to find that file?

Okay, then where is a good tutorial to learn laravel?

Thanks in advance.

4
Contributors
22
Replies
101
Views
6 Months
Discussion Span
Last Post by davy_yg
Featured Replies
  • 1
    diafol 3,720   6 Months Ago

    @cereal. I don.t think he.s answering any questions so that we can resolve this in under 30 posts. You.ve got more patience than me ;) Read More

0

I'd find it easier to install the following:

  1. Fresh install of XAMPP with PHP7 (uninstall previous versions - but backup any SQLs / Sites first)
  2. Install Composer (uninstall any previous versions) - this is a must - old versions of composer don't like v7
  3. Install Laravel to the directory of your choice (in htdocs)
  4. Remember to set up the correct settings in vconf and etc/hosts

The above assumes Windows set up and Apache.

If you don't get the Laravel page - try to isolate the step where things went wrong. It could just be step 4. In which case show your file contents.

0

Hey, where to get the newest version of composer? I thought I already install the newest version of composer and that php7.dll errors is still missing.

0

Another question: how to tell what version of laravel from the laravel files? How to check it? I have a laravel file which I cannot tell what version is it?

0

How to run artisan from laravel root directory? Since the extension is file, it requires another software to run artisan.

1

@cereal. I don.t think he.s answering any questions so that we can resolve this in under 30 posts. You.ve got more patience than me ;)

Votes + Comments
heh
0

Only EasyPHP 14.1VC9 Web Server that I installed. That's my web server.

0

From the site: http://www.easyphp.org/save-easyphp-devservervc9-latest.php - be careful it automatically starts a download of the easyphp executable!

The page states:

EasyPHP DevServer 14.1 VC9
PHP 5.4.x / 5.3.x / 5.2.x, Apache 2.4.7 VC9, MySQL 5.6.15, PhpMyAdmin, Xdebug + modules + components

So, PHP5.4 as the maximum?

Laravel 5.4 will NOT play nicely with that anyhow. From https://laravel.com/docs/5.4

However, if you are not using Homestead, you will need to make sure your server meets the following requirements:
PHP >= 5.6.4
OpenSSL PHP Extension
PDO PHP Extension
Mbstring PHP Extension
Tokenizer PHP Extension
XML PHP Extension

You need PHP v5.6.4 - I had to upgrade my version of PHP to 7 some time ago due to this.

Not sure why all this is such a mystery and "difficult to get" info.

Edited by diafol

0

How to run artisan from laravel root directory? Since the extension is file, it requires another software to run artisan.

Assuming you have added php.exe to your PATH (env variables). Composer should be added to PATH if you used the Windows installer. Laravel should be available globally too, but it does depend on how you installed it. Artisan commands are like the following

php artisan make:migration create_profiles_table

This can be run in the console from the webroot of your local site, e.g. (for me):

C:\xampp\htdocs\laravelBlog>php artisan make:migration create_profiles_table

Not sure what the structure EasyPHP gives.

0

I have tried to install EasyPHP 17.0 and when I try to run Start/ Restart All Server this error appears:

The program can't start because php7.dll is missing from your computer. Try reinstalling the program to fix this problem.

I have tried to reinstall the program like twice but the same error appears. I thought EasyPHP 17.0 should be compatible with PHP 7.0 already.

0

I finally download php7.dll --> http://fixfile.info/php7.dll/m-download-50.html

Then another error:

api-ms-win-crt-runtime-l1-1-0-dll is missing

I try to install Visual C++ 2015 Redistributable (x64) - Setup Failed due to software counterfeiting (unoriginal version).

Do you think I need an original version of Windows 7 to make this works?

Is this a must ?

0

What are you talking about? Is your windows 7 a pirate / stolen? This is a general Windows problem now.

0

Nevermind I just purchase the new one Windows 10 (original version) to make it works. I am still facing slightly different problem now.

The program can't start because MSVCR110.dll is missing from your computer.

I wonder why?

0

I already install Visual studio 2017. Now:

Eds-dashboard.exe - Application Error

The application was unable to start correctly (0x000007b). Click OK to close the application.

Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.