Hi All,

I am getting the below error when i am trying to run my app.
I am sun one app server.I have deployed my classes and jsp using the deply tool.


org.apache.jasper.JasperException: Unable to compile class for JSP

No Java compiler was found to compile the generated source for the JSP.
This can usually be solved by copying manually $JAVA_HOME/lib/tools.jar from the JDK
to the common/lib directory of the Tomcat server, followed by a Tomcat restart.
If using an alternate Java compiler, please check its installation and access path.

org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:132)
	org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:356)
	org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:420)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:463)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:444)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:557)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:305)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:306)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:253)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:861)
	sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	java.lang.reflect.Method.invoke(Method.java:324)
	org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:289)
	java.security.AccessController.doPrivileged(Native Method)
	javax.security.auth.Subject.doAsPrivileged(Subject.java:500)
	org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:311)
	org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:205)

Please help

I will bet that currently, you have a JRE_HOME defined in your Tomcat configuration, but not a JAVA_HOME. Define JAVA_HOME in your Tomcat configuration and the problem should go away.

thanks Masijade for the reply.......i have solved the error......
i checked the error logs.....there were some problem compiling
while compiling the class..................i corrected those and now
its working fine...........

This question has already been answered. Start a new discussion instead.