Dear Folks,

This is anand, i m new to Tomcat5.5, i have given my directory structure i think nothing wrong with this but it is showing some error.
Webapps
I
anand
I
WEB-INF, helloworld.jsp
I
classes,web.xml

If i try to run my simple helloworld jsp program it is showing error like this

HTTP Status 500 -


--------------------------------------------------------------------------------

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Wrapper cannot find servlet class anand-jsp or a class it depends on
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:874)
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
java.lang.Thread.run(Unknown Source)

root cause

java.lang.ClassNotFoundException: anand-jsp
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1362)
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1208)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:874)
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
java.lang.Thread.run(Unknown Source)


note The full stack trace of the root cause is available in the Apache Tomcat/5.5.25 logs.

Perhaps there is an issue with your web.xml file.

How are you outputting your Hello World program? E.g. using a class or sciptlet in the JSP page.

Perhaps there is an issue with your web.xml file.

How are you outputting your Hello World program? E.g. using a class or sciptlet in the JSP page.

My JSP file contains only this code,

<head>
<title> My First JSP</title>
<body>
<%@page import="java.util.*"%>
welcome to JSP
The Current Date <%= new Date()%>
</body>
</html>

It works fine for me. I think that it does't like the import statement (can't find the class).

See if the following works.

<html>
<body>
<%
      out.print("Hello World");
%>
</body>
</html>

I'm new to JSP too so if any experts can help feel free.:P

how can i input data to the perticular database using a simple frame i created?
eg:frame caontaines a text box for name now i have to ebter name in this text box and this name i want to store to that database
plz help me
thanks

This article has been dead for over six months. Start a new discussion instead.