Suddenly, the site no longer works properly for me when I use Konqueror 3.5.9 on debian. It had been working as well as could be expected before then (e.g., flash typically required a page reload before it'd work correctly, but the drop-down menus worked.)

In the past week or so, the drop-down menus (forum and daniweb) have stopped working. On mouseover, the forum menus pretty-much disappear, leaving just the grey background. Also, it seems that while the mouse is moving over the menu header, the 'label' flickers on and off. Once the mouse stops moving or moves off, the text disappears. The forum menus never appear, and hte DW menus do not appear when the header is clicked.

They work OK in iceweasel.

Did the menu code change? Or was Linus right in dropping KDE? I suspect the latter, because KDE has been experiencing a steady decline in quality since v3.2 or so. At least on Debian.

Please try clearing your temporary internet files (browser cache) and then sending screenshots.

Cleaned all daniweb stuff from cache. No change. Attached is a shot of the Konqueror winder. You can see menu items are missing; the links aren't there either. The drop-down menus don't appear. If I click quickly and repeatedly, I might be able to activate one of the forum links before it 'permanently' disappears. As I move the mouse over the forum menu item, it 'flickers' on and off until it disappears.

When I click "Control Panel", nothing happens (the drop-down menu is supposed to appear).

If I tell konqueror to identify itself as IE6, the links and images don't disappear and I can click them. But the drop-down menus still don't appear.

If I turn JS off, the forum images still flicker, but they don't disappear permanently.

And weirder still, during mouseover when the image vanishes, the link is clickable, but when the image is visible, the link is not clickable.

Disabling plugins (flash) made no difference, except the menus become 'active' sooner. With flash active, the drop-down forum menus are not available until the ads have loaded (or until the plugin has started; not sure which).

I even saved a copy of the page and tried xhtml strict and html4 strict, to no avail. OK, I even tried konqueror 4.1 on another 'puter (kubuntu); the forum menu images flicker but don't disappear, and the link still alternates with the image.

As I said, it's almost guaranteed to be a KDE problem. Konqueror *used* to be a very good implementation of the standards, but has been slipping for some years now. At least it has from my perspective. One of these days when I have time, I'll create a fresh user on my system and see if it's just cruft built up in my KDE files over the past 6 years or so.

I know just how painful it is to make a web site display correctly on a myriad of browsers; I've been trying to do it for 7 years now. As was the case with X.25 libraries years ago, every browser implements the WWW specs differently. And none of them implement the specs right. Thus is it nearly impossible to create a somewhat dynamic web page that works and looks nearly the same on most browsers, and by God it's painful! I know people who've given up and chosen to support exactly one browser.


It used to work last week though?

It used to work last week though?

Hmmm. I was on a road trip 6/22-6/30, and didn't have KDE then (laptop is XP only). It may have been working OK before 6/22, and I'm almost certain it was OK before 6/14.

Wish I could be more specific; when one browser stops working, I just go to the other one. Some folks tell me I'm suffering early-onset CRS.